Ticket #1004 (closed bug: duplicate)

Opened 5 years ago

Last modified 5 years ago

t/op/calling.t, t/pmc/sub.t failed at r41244 during 'make testj'

Reported by: jkeenan Owned by:
Priority: normal Milestone:
Component: core Version: 1.5.0
Severity: medium Keywords:
Cc: bacek Language:
Patch status: Platform:

Description

usr/local/bin/perl t/harness --gc-debug --running-make-test -j --runcore-tests

...

t/op/calling.t                     (Wstat: 256 Tests: 94 Failed: 1)
  Failed test:  52
  Non-zero exit status: 1
t/op/trans.t                       (Wstat: 0 Tests: 22 Failed: 0)
  TODO passed:   13
t/pmc/sub.t                        (Wstat: 256 Tests: 68 Failed: 1)
  Failed test:  36
  Non-zero exit status: 1
Files=214, Tests=5830, 196 wallclock secs ( 0.88 usr  0.15 sys + 31.29 cusr  5.22 csys = 37.54 CPU)
Result: FAIL
make[1]: *** [testj] Error 1

Attachments

20090913.41254.makej.failures.darwin.ppc.txt Download (1.4 KB) - added by jkeenan 5 years ago.
The two tests fail under 'makej' on Darwin/PPC as well

Change History

  Changed 5 years ago by jkeenan

  • component changed from none to core

Observed on Linux/i386 -- but I suspect this is probably not platform-specific.

  Changed 5 years ago by jkeenan

Failures appeared in or before r41239:

[li11-226:41239] 541 $  perl t/harness --gc-debug -j t/op/calling.t t/pmc/sub.t
t/op/calling.t .. 5/94 
not ok 16 - argc mismatch, too many - no getparams # TODO no get_params at all
t/op/calling.t .. 49/94 
#   Failed test 'clone_key_arg'
#   at t/op/calling.t line 1409.
# Exited with error code: [SIGNAL 6]
# Received:
# src/call/context.c:1464: failed assertion 'Parrot_pcc_get_regs_used(interp, ctx, REGNO_INT) > idx'
# Backtrace - Obtained 21 stack frames (max trace depth is 32).
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x400d59e2]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(Parrot_confess+0x9a) [0x400d5b4a]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(Parrot_pcc_get_INTVAL_reg+0xa5) [0x400f8835]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(key_integer+0x1db) [0x400fc5fb]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x40268c34]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4020ebe7]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4020ee32]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4020f080]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4020f368]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4011e7a2]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4011f4de]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4011e68f]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x400f6e91]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x400f7155]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(Parrot_runops_fromc_args+0xbd) [0x400f7e9d]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(Parrot_runcode+0x192) [0x400d25c2]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x40346bec]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(imcc_run+0x369) [0x40346f69]
# ./parrot [0x8048908]
# /lib/tls/libc.so.6(__libc_start_main+0xc8) [0x40f95ea8]
# ./parrot [0x80487b1]
# 
# Expected:
# key 3 42
# ok
# 
t/op/calling.t .. 79/94 not ok 93 - arg mismatch with no params # TODO RT #39844
# Looks like you failed 1 test of 94.
t/op/calling.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/94 subtests 
t/pmc/sub.t ..... 25/68 
#   Failed test 'caller introspection via interp'
#   at t/pmc/sub.t line 838.
# Exited with error code: [SIGNAL 6]
# Received:
# src/call/context.c:1464: failed assertion 'Parrot_pcc_get_regs_used(interp, ctx, REGNO_INT) > idx'
# Backtrace - Obtained 21 stack frames (max trace depth is 32).
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x400d59e2]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(Parrot_confess+0x9a) [0x400d5b4a]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(Parrot_pcc_get_INTVAL_reg+0xa5) [0x400f8835]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(key_integer+0x1db) [0x400fc5fb]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x40268c34]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4020ebe7]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4020ee32]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4020f080]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4020f368]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4011e7a2]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4011f4de]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x4011e68f]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x400f6e91]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x400f7155]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(Parrot_runops_fromc_args+0xbd) [0x400f7e9d]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(Parrot_runcode+0x192) [0x400d25c2]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0 [0x40346bec]
# /home/jimk/work/41239/blib/lib/libparrot.so.1.5.0(imcc_run+0x369) [0x40346f69]
# ./parrot [0x8048908]
# /lib/tls/libc.so.6(__libc_start_main+0xc8) [0x40f95ea8]
# ./parrot [0x80487b1]
# 
# Expected:
# main foo
# Bar bar
# subname: bar
# Bar foo
# caller 0 foo
# caller 1 bar
# caller 2 foo
# caller 3 main
# Bar foo
# caller 0 foo
# caller 1 main
# ok
# 
t/pmc/sub.t ..... 68/68 
not ok 68 - Thaw PIR subclass # TODO See TT#132
# Looks like you failed 1 test of 68.
t/pmc/sub.t ..... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/68 subtests 

Test Summary Report
-------------------
t/op/calling.t (Wstat: 256 Tests: 94 Failed: 1)
  Failed test:  52
  Non-zero exit status: 1
t/pmc/sub.t   (Wstat: 256 Tests: 68 Failed: 1)
  Failed test:  36
  Non-zero exit status: 1
Files=2, Tests=162, 12 wallclock secs ( 0.04 usr  0.00 sys +  1.70 cusr  0.35 csys =  2.09 CPU)
Result: FAIL

SIGNAL 6:

       SIGABRT	     6	     Core    Abort signal from abort(3)

  Changed 5 years ago by jkeenan

My last completely successful make fulltest on Linux was on 20090905 at r41018. So problem has emerged within last 7 days.

  Changed 5 years ago by jkeenan

  • cc bacek added

Tests pass at: 41018 Tests pass at: 41022

t/op/calling.t .. 16/94 
not ok 16 - argc mismatch, too many - no getparams # TODO no get_params at all
t/op/calling.t .. 88/94 not ok 93 - arg mismatch with no params # TODO RT #39844
t/op/calling.t .. ok     
t/pmc/sub.t ..... ok     
All tests successful.
Files=2, Tests=161, 20 wallclock secs ( 0.04 usr  0.00 sys +  1.72 cusr  0.20 csys =  1.96 CPU)
Result: PASS

Tests fail at: 41023

[li11-226:41023] 565 $  perl t/harness --gc-debug -j t/op/calling.t t/pmc/sub.tt/op/calling.t .. 15/94 not ok 16 - argc mismatch, too many - no getparams # TODO no get_params at all
t/op/calling.t .. 44/94 
#   Failed test 'clone_key_arg'
#   at t/op/calling.t line 1409.
# Exited with error code: [SIGNAL 6]
# Received:
# src/gc/alloc_register.c:492: failed assertion 'Parrot_pcc_get_regs_used(interp, ctx, REGNO_INT) > idx'
# Backtrace - Obtained 21 stack frames (max trace depth is 32).
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x400d5c32]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(Parrot_confess+0x9a) [0x400d5d9a]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(Parrot_pcc_get_INTVAL_reg+0xa5) [0x400e3de5]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(key_integer+0x1db) [0x400fc9fb]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x402660e4]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4020bec7]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4020c112]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4020c360]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4020c648]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4011f452]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4011f4e8]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4011efbe]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x400f82b1]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x400f8577]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(Parrot_runops_fromc_args+0xbd) [0x400f92bd]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(Parrot_runcode+0x114) [0x400d27a4]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x40344aac]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(imcc_run+0x369) [0x40344e29]
# ./parrot [0x80488f8]
# /lib/tls/libc.so.6(__libc_start_main+0xc8) [0x40f8bea8]
# ./parrot [0x80487a1]
# 
# Expected:
# key 3 42
# ok
# 
t/op/calling.t .. 88/94 not ok 93 - arg mismatch with no params # TODO RT #39844
# Looks like you failed 1 test of 94.
t/op/calling.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/94 subtests 
t/pmc/sub.t ..... 33/67 
#   Failed test 'caller introspection via interp'
#   at t/pmc/sub.t line 838.
# Exited with error code: [SIGNAL 6]
# Received:
# src/gc/alloc_register.c:492: failed assertion 'Parrot_pcc_get_regs_used(interp, ctx, REGNO_INT) > idx'
# Backtrace - Obtained 21 stack frames (max trace depth is 32).
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x400d5c32]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(Parrot_confess+0x9a) [0x400d5d9a]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(Parrot_pcc_get_INTVAL_reg+0xa5) [0x400e3de5]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(key_integer+0x1db) [0x400fc9fb]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x402660e4]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4020bec7]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4020c112]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4020c360]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4020c648]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4011f452]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4011f4e8]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x4011efbe]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x400f82b1]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x400f8577]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(Parrot_runops_fromc_args+0xbd) [0x400f92bd]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(Parrot_runcode+0x114) [0x400d27a4]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0 [0x40344aac]
# /home/jimk/work/41023/blib/lib/libparrot.so.1.5.0(imcc_run+0x369) [0x40344e29]
# ./parrot [0x80488f8]
# /lib/tls/libc.so.6(__libc_start_main+0xc8) [0x40f8bea8]
# ./parrot [0x80487a1]
# 
# Expected:
# main foo
# Bar bar
# subname: bar
# Bar foo
# caller 0 foo
# caller 1 bar
# caller 2 foo
# caller 3 main
# Bar foo
# caller 0 foo
# caller 1 main
# ok
# 
t/pmc/sub.t ..... 61/67 # Looks like you failed 1 test of 67.
t/pmc/sub.t ..... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/67 subtests 

Test Summary Report
-------------------
t/op/calling.t (Wstat: 256 Tests: 94 Failed: 1)
  Failed test:  52
  Non-zero exit status: 1
t/pmc/sub.t   (Wstat: 256 Tests: 67 Failed: 1)
  Failed test:  36
  Non-zero exit status: 1
Files=2, Tests=161, 12 wallclock secs ( 0.05 usr  0.00 sys +  1.72 cusr  0.29 csys =  2.06 CPU)
Result: FAIL

Tests fail at: 41031 Tests fail at: 41050 Tests fail at: 41100 Tests fail at: 41200

So r41023 is suspect.

follow-up: ↓ 6   Changed 5 years ago by bacek

It's a duplicate of #983.

in reply to: ↑ 5   Changed 5 years ago by jkeenan

Replying to bacek:

It's a duplicate of #983.

... which I have reopened because the problem was not solved there.

Changed 5 years ago by jkeenan

The two tests fail under 'makej' on Darwin/PPC as well

  Changed 5 years ago by jkeenan

Attached file demonstrating that the problem exists on Darwin/PPC in addition to Linux/i386.

  Changed 5 years ago by bacek

  • status changed from new to closed
  • resolution set to duplicate

Failing tests were marked with SKIP. Resolving ticket as duplicate.

Note: See TracTickets for help on using tickets.