Ticket #1027 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

PIR-only segfault

Reported by: coke Owned by:
Priority: normal Milestone:
Component: none Version: trunk
Severity: fatal Keywords:
Cc: Language:
Patch status: Platform:

Description (last modified by coke) (diff)

See  Original Ticket.

This code segfaults in trunk:

.sub main :main
push_eh handler
test()
## NB: This makes sure the sub call PC is sufficiently
## different from the exception handler PC.
print "foo\n"
print "bar\n"
.return ()
handler:
.local pmc exception
.local string message
.get_results (exception, message)
print "Error: "
print message
.end

.sub test
## Throw an exception.
$P0 = new 'Exception'
$P0 = 'oops'
throw $P0
.end

Change History

Changed 5 years ago by coke

  • description modified (diff)

Changed 5 years ago by NotFound

The problem is that .get_results (exception, message) is an error, and throws an exception. The exception is catched by the same handler, and throws again, and is catched...

Changed 5 years ago by coke

  • status changed from new to closed
  • resolution set to fixed

This TODO was uncommented in r42023 by mikehh; resolving ticket.

Note: See TracTickets for help on using tickets.