Ticket #1098 (closed cage: fixed)

Opened 5 years ago

Last modified 5 years ago

[CAGE] rename parrot_nqp to parrot-nqp

Reported by: fperrad Owned by: pmichaud
Priority: normal Milestone:
Component: nqp Version: 1.6.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: all

Description

Since r41417, NQP is installed in executable form (previously only in pbc form)

If NQP is a language like another one, the executable must be named parrot-nqp (not parrot_nqp), like parrot-abc, etc.

See PDD30.

Change History

  Changed 5 years ago by pmichaud

The only place that PDD30 mentions using "parrot-" instead of "parrot_" is in a parenthetical comment, the focus of which is to not use the language name as the name of the executable. In other words, the use of "parrot-lang" is currently a suggestion, not a requirement.

As such, I decided to err on the side of being consistent with the other parrot executables, all of which currently have underscores instead of hyphens.

I'll be very happy to switch nqp to use a hyphen instead (and personally prefer that), but if we do that I'd like to make a strong case that the other parrot executables should use hyphens as well. Otherwise we have to remember when to use one or the other, or explain the inconsistency (and the explanations I can imagine all sound pretty contrived).

Pm

  Changed 5 years ago by fperrad

Currently, we have :

  • parrot_config
  • parrot_debugger
  • parrot_nqp

maybe, you want include too :

  • pbc_disassemble
  • pbc_dump
  • pbc_merge
  • pbc_to_exe

I think we can't rename parrot_config, without a deprecation cycle. Because that breaks building tools of most languages.

But we could rename parrot_nqp now, because it is new and never released.

follow-up: ↓ 4   Changed 5 years ago by dukeleto

Plumage currently depends on the spelling 'parrot_nqp' (it has a Configure script and test harness written in NQP), but obviously I could change that if necessary. Since we already have parrot_config and parrot_debugger, I vote for staying with underscores and updating PDD30.

in reply to: ↑ 3   Changed 5 years ago by darbelo

Replying to dukeleto:

Plumage currently depends on the spelling 'parrot_nqp' (it has a Configure script and test harness written in NQP), but obviously I could change that if necessary. Since we already have parrot_config and parrot_debugger, I vote for staying with underscores and updating PDD30.

I disagree on this point. There is strong precedent in language names for a "parrot-" prefix, and '-' seems to be more popular than '_' (look at the /usr/bin or /usr/local/bin directory of your nearest unix) in program names.

Also the sentiment I've seen on #parrot indicates a preference for parrot-nqp over parrot_nqp. I feel we should rename parrot-nqp now to follow the convention set by other languages. And, if we decide we want consistency for all executable names, rename parrot_config and the others in the next deprecation point.

  Changed 5 years ago by dukeleto

I really am not very particular on _ vs - . Let's just pick one and stick to it.

  Changed 5 years ago by fperrad

  • status changed from new to closed
  • resolution set to fixed

Done with nqp-rx.

Note: See TracTickets for help on using tickets.