Ticket #1135 (closed bug: fixed)

Opened 5 years ago

Last modified 4 years ago

t/op/annotate-old.t fails using -f core

Reported by: coke Owned by:
Priority: normal Milestone:
Component: none Version: trunk
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

Test appears to fail as expected, but not every core displays line numbers in stacktraces.

(Tests that test for this should check for the correct value in the runcores that support it, and -1 otherwise.)

$ perl t/harness -f t/op/annotate-old.t
t/op/annotate-old.t .. 1/1
#   Failed test 'unhandled exception from loaded function'
#   at t/op/annotate-old.t line 26.
#                   'too many positional arguments: 5 passed, 2 expected
# current instr.: 'parrot;Test;More;ok' pc 31 (runtime/parrot/library/Test/More.pir:100)
# called from Sub 'main' pc -1 ((unknown file):-1)
# '
#     doesn't match '/(foobar:42)/
# '
# './parrot --runcore=fast -D40  "/home/coke/sandbox/parrot/t/op/annotate-old_1.pir"' failed with exit code 1
# Looks like you failed 1 test of 1.
t/op/annotate-old.t .. Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests

Test Summary Report
-------------------
t/op/annotate-old.t (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=1, Tests=1,  0 wallclock secs ( 0.02 usr  0.00 sys +  0.05 cusr  0.01 csys =  0.08 CPU)
Result: FAIL

Change History

Changed 5 years ago by mikehh

it also fails in the -g core with the same failures

Changed 5 years ago by mikehh

  • version changed from 1.6.0 to trunk

marked the test as TODO in the fast and cgoto runcores in r42086

the fast and cgoto runcores do not display line numbers in stack traces

an option would be to modify the test as per t/op/debuginfo.t but I am not altogether happy with that solution - I think the cores should get the line numbers, if this is at all possible, and so marked as TODO rather than modify the test

Changed 4 years ago by mikehh

The test now passes on all platforms available to me:

t/op/annotate-old.t - TODO passed: 1 in testf

I removed the TODO in r47508

If there are no reported failures elsewhere I will close this ticket in a couple of days.

Note: the test needs to be run in fulltest or testf

Changed 4 years ago by jkeenan

Confirmed on linux/i386 (make testf).

Changed 4 years ago by jkeenan

make testf also passes on Darwin/ppc (with t/op/exit.t TODO passed: 6).

kid51

Changed 4 years ago by mikehh

  • status changed from new to closed
  • resolution set to fixed

Looks like this can be closed now.

Note: See TracTickets for help on using tickets.