Ticket #1146 (closed bug: wontfix)

Opened 5 years ago

Last modified 4 years ago

same code works on windows, not on mac

Reported by: kjs Owned by: kjs
Priority: normal Milestone:
Component: pirc Version: 1.6.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description (last modified by plobsing) (diff)

This program:

.sub main
  a()
  b()
.end
.sub a
  say "a"
.end
.sub b
  say "b"
.end

Works fine on windows, whereas on MacOS 10.6, I see:

$ ./pirc -b -x inv.pir a maximum recursion depth exceeded current instr.: 'b' pc 26 (inv.pir:11) called from Sub 'main' pc -1 ((unknown file):-1)

Not tested in Linux. Note: PIRC is NOT built as part of the Parrot build process. In order to get the PIRC executable:

cd compilers/pirc
make

Change History

Changed 5 years ago by kjs

  • description modified (diff)

Changed 5 years ago by kjs

  • description modified (diff)

Changed 5 years ago by jkeenan

Here are some results.

Darwin/PPC (Mac OS X 10.4.11):

$ cd cd compilers/pirc && make
$ ./pirc  -b -x inv.pir
a
b

Linux/i386:

$ cd cd compilers/pirc && make
$ ./pirc  -b -x inv.pir
a
b

So I could not reproduce the problem on either box to which I have access.

kid51

Changed 4 years ago by plobsing

  • description modified (diff)

Changed 4 years ago by plobsing

  • description modified (diff)

Changed 4 years ago by plobsing

  • description modified (diff)

Changed 4 years ago by plobsing

  • status changed from new to closed
  • resolution set to wontfix
  • description modified (diff)
Note: See TracTickets for help on using tickets.