Ticket #1214 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

config/inter/charset.pm generates incorrect makefile deps

Reported by: coke Owned by: coke
Priority: normal Milestone:
Component: build Version:
Severity: medium Keywords:
Cc: jkeenan Language:
Patch status: Platform:

Description

The section of the makefile generated by this config step is missing dependencies:

one example from tools/dev/checkdepend.pl :

#   Failed test 'src/string/charset/unicode'
#   at tools/dev/checkdepend.pl line 78.
#          got: 'src/string/charset/unicode.h src/string/charset/ascii.h src/string/charset/unicode.c $(NONGEN_HEADERS)'
#     expected: 'tables.h'

Change History

  Changed 5 years ago by coke

config/inter/encoding.pm suffers from a similar problem, e.g.:

#   Failed test 'src/string/encoding/utf16'
#   at tools/dev/checkdepend.pl line 78.
#          got: 'src/string/encoding/utf16.h src/string/encoding/utf16.c $(NONGEN_HEADERS)'
#     expected: '../unicode.h'

  Changed 5 years ago by jkeenan

  • cc jkeenan added

follow-up: ↓ 4   Changed 5 years ago by jkeenan

Coke:

I was never aware of tools/dev/checkdepends.pl until I saw this ticket.

When I ran it, I got 6 errors -- which appears to be more than you got.

Here is an edited version of my results with prove:

$ cat edited.charset.errors.txt 
not ok 21 - src/string/charset/unicode

#   Failed test 'src/string/charset/unicode'
#   at tools/dev/checkdepend.pl line 78.
#          got: 'src/string/charset/unicode.h src/string/charset/ascii.h 
                 src/string/charset/unicode.c $(NONGEN_HEADERS)'
#     expected: 'tables.h'
# skipping parrot/parrot.h...
# ...
not ok 27 - src/string/encoding/ucs2

#   Failed test 'src/string/encoding/ucs2'
#   at tools/dev/checkdepend.pl line 78.
#          got: 'src/string/encoding/ucs2.h 
                 src/string/encoding/ucs2.c $(NONGEN_HEADERS)'
#     expected: '../unicode.h'
# ...
not ok 50 - src/string/encoding/utf8

#   Failed test 'src/string/encoding/utf8'
#   at tools/dev/checkdepend.pl line 78.
#          got: 'src/string/encoding/utf8.h 
                 src/string/encoding/utf8.c $(NONGEN_HEADERS)'
#     expected: '../unicode.h'
# skipping parrot/parrot.h...
# ...
not ok 94 - src/string/charset/ascii

#   Failed test 'src/string/charset/ascii'
#   at tools/dev/checkdepend.pl line 78.
#          got: 'src/string/charset/ascii.h src/string/charset/ascii.h 
                 src/string/charset/ascii.c $(NONGEN_HEADERS)'
#     expected: 'tables.h'
# skipping parrot/parrot.h...
# ...
not ok 128 - src/string/charset/iso-8859-1

#   Failed test 'src/string/charset/iso-8859-1'
#   at tools/dev/checkdepend.pl line 78.
#          got: 'src/string/charset/iso-8859-1.h src/string/charset/ascii.h 
                 src/string/charset/iso-8859-1.c $(NONGEN_HEADERS)'
#     expected: 'tables.h'
# skipping parrot/parrot.h...
# ...
not ok 164 - src/string/encoding/utf16

#   Failed test 'src/string/encoding/utf16'
#   at tools/dev/checkdepend.pl line 78.
#          got: 'src/string/encoding/utf16.h 
                 src/string/encoding/utf16.c $(NONGEN_HEADERS)'
#     expected: '../unicode.h'
1..164
# Looks like you failed 6 tests of 164.

How/why are these different from your results?

Thank you very much.

kid51

in reply to: ↑ 3   Changed 5 years ago by coke

Replying to jkeenan:

Coke: I was never aware of tools/dev/checkdepends.pl until I saw this ticket.

That's because it didn't exist until about a hour before this ticket was opened. =-)

When I ran it, I got 6 errors -- which appears to be more than you got.

Nope. I just gave one example of each type. Six is how many I got.

  Changed 5 years ago by coke

  • owner set to coke

follow-up: ↓ 7   Changed 5 years ago by coke

This doesn't seem to be an issue in the one_make branch; can close this ticket once it's merged back.

in reply to: ↑ 6   Changed 5 years ago by jkeenan

  • status changed from new to closed
  • resolution set to fixed

Replying to coke:

This doesn't seem to be an issue in the one_make branch; can close this ticket once it's merged back.

Confirmed after merge at r43593. Closing this ticket.

Have posted results of checkdepend.pl at that revision on  http://trac.parrot.org/parrot/wiki/BuildTaskList.

Note: See TracTickets for help on using tickets.