Ticket #1301 (closed todo: fixed)

Opened 5 years ago

Last modified 4 years ago

Update RT references in repository/wiki

Reported by: coke Owned by:
Priority: normal Milestone:
Component: docs Version:
Severity: low Keywords:
Cc: jkeenan Language:
Patch status: Platform:

Description

parrot's  http://rt.perl.org/rt3/ queue is now empty.

there are 175 instances in the repository now of "RT #" and many urls containing rt.perl.org.

My suggestion:

  • Find any references to RTs that have been transferred to trac and convert their references to a simple "TT #nnn" (no URLS. we can make 'make html' smarter about this if necessary.)
  • If an RT was rejected, it probably shouldn't be referenced from the repository
  • Any remaining RTs are probably references to bugs or discussions that were resolved. They can remain; as with the TT's, don't use a full URL; just refer to the "RT #nnn"
  • Update the glossary to insure that TT and RT point to their respective base urls. (RT's entry should mention the historical nature of those references.)

Attachments

RT.references.diff.gz Download (19.0 KB) - added by jkeenan 5 years ago.
References to RT deleted from repository Nov 20-21 2009

Change History

in reply to: ↑ description   Changed 5 years ago by jkeenan

Replying to coke:

there are 175 instances in the repository now of "RT #" and many urls containing rt.perl.org.

Can you post your grep, etc., so we can reproduce? Thanks.

follow-ups: ↓ 3 ↓ 4   Changed 5 years ago by coke

ack --text 'RT #'

in reply to: ↑ 2   Changed 5 years ago by jkeenan

Replying to coke:

  ack --text 'RT #'

... which, it should be noted, requires a more recent version of App::Ack than I had installed. So if you have an older version of that module, it's time to upgrade.

kid51

in reply to: ↑ 2 ; follow-up: ↓ 5   Changed 5 years ago by jkeenan

Replying to coke:

ack --text 'RT #'

And before I saw this post I had rolled my own:

find . -type f -a ! -path '*/.svn*' -a ! -path '*/cover*' | xargs grep -n -E '\bRT\b'

in reply to: ↑ 4 ; follow-up: ↓ 7   Changed 5 years ago by jkeenan

  • owner set to jkeenan
  • status changed from new to assigned

Replying to jkeenan:

Replying to coke:

I've made it about halfway through the list I generated. Since we search for the string RT, where I think we should leave a permanent link to discussion in an RT item, I've been changing that to a full URL.

If that's not satisfactory, feel free to second-guess me.

Thank you very much.

kid51

  Changed 5 years ago by coke

On Fri, Nov 20, 2009 at 10:57 PM, Parrot
<parrot-tickets@lists.parrot.org> wrote:
> #1301: Update RT references in repository/wiki
> --------------------+-------------------------------------------------------
>  Reporter:  coke    |       Owner:  jkeenan
>     Type:  todo    |      Status:  assigned
>  Priority:  normal  |   Milestone:
> Component:  docs    |     Version:
>  Severity:  low     |    Keywords:
>     Lang:          |       Patch:
>  Platform:          |
> --------------------+-------------------------------------------------------
> Changes (by jkeenan):
>
>  * owner:  => jkeenan
>  * status:  new => assigned
>
>
> Comment:
>
>  Replying to [comment:4 jkeenan]:
>  > Replying to [comment:2 coke]:
>
>  I've made it about halfway through the list I generated.  Since we search
>  for the string `RT`, where I think we should leave a permanent link to
>  discussion in an RT item, I've been changing that to a full URL.
>
>  If that's not satisfactory, feel free to second-guess me.

That's a good plan.[0]

>  Thank you very much.
>
>  kid51
>
> --
> Ticket URL: <https://trac.parrot.org/parrot/ticket/1301#comment:5>
> Parrot <https://trac.parrot.org/parrot/>
> Parrot Development
>

[0] What you're doing, that is, not second guessing you. =-)

-- 
Will "Coke" Coleda

in reply to: ↑ 5   Changed 5 years ago by jkeenan

  • status changed from assigned to new
  • owner jkeenan deleted

Replying to jkeenan:

Replying to jkeenan:

Replying to coke:

The references in the repository have been updated. I'm attaching a diff, so that if in certain cases you think I deleted too much, you can revert as needed.

I'll leave references in the Wiki to someone else.

kid51

Changed 5 years ago by jkeenan

References to RT deleted from repository Nov 20-21 2009

  Changed 5 years ago by jkeenan

  • cc jkeenan added

  Changed 4 years ago by coke

  • status changed from new to closed
  • resolution set to fixed

Any references left in the wiki can be considered historical. Closing ticket.

Note: See TracTickets for help on using tickets.