Ticket #1358 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

'make realclean' doesn't clean some nqp-rx files

Reported by: moritz Owned by: coke
Priority: normal Milestone:
Component: build Version: 1.8.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

After a reconfigure, rebuild and realclean, git status of my git-svn parrot checkout shows that the following files have survived the cleansing:

# Untracked files:
#   (use "git add <file>..." to include in what will be committed)
#
#       parrot-nqp
#       parrot-nqp.c
#       parrot-nqp.o
#       parrot-nqp.pbc
#       runtime/parrot/library/HLL.pbc
#       runtime/parrot/library/P6Regex.pbc
#       runtime/parrot/library/Regex.pbc
#       runtime/parrot/library/nqp-rx.pbc

Change History

Changed 5 years ago by jkeenan

  • component changed from none to build

In a regular Subversion checkout, at least, I cannot reproduce your problem. All the files listed are covered by the ext-clean target:

   1459 ext-clean:
   1460     $(MAKE) ext/nqp-rx clean
   1461     $(RM_RF) runtime/parrot/library/HLL.pbc \
   1462   runtime/parrot/library/P6Regex.pbc \
   1463   runtime/parrot/library/Regex.pbc \
   1464   runtime/parrot/library/nqp-rx.pbc \
   1465   parrot-nqp*

and make ext-clean is called within make clean:

   1679 clean : \
   1680     test-clean \
   1681     prog-clean \
...
   1690     ext-clean \

I found that in a Subversion checkout make clean was sufficient to cleanse those files, which implies that make realclean would also do so.

So we'll need feedback from git-svn parrot devs (which I am not :-)).

Thank you very much.

kid51

Changed 5 years ago by coke

  • owner set to coke

FYI, I had only fixed this in r42897, and that target didn't even exist until r42893.

Changed 5 years ago by coke

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.