Ticket #1436 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Crash on parsing unknown command line arguments.

Reported by: fperrad Owned by:
Priority: normal Milestone: 2.1
Component: none Version: 2.0.0
Severity: medium Keywords:
Cc: bacek Language:
Patch status: Platform: all

Description (last modified by coke) (diff)

On Windows/mingw, the following command:

> parrot.exe --foo

causes a popup window with the following message:

parrot.exe has encountered a problem and needs to close.
We are sorry for the inconvenience.

This issue starts after r43851.

Attachments

fix_longopt.patch Download (5.9 KB) - added by fperrad 4 years ago.
s/Parrot_snprintf/snprintf/g; and remove interp

Change History

Changed 4 years ago by coke

  • description modified (diff)
  • milestone set to 2.1

Changed 4 years ago by bacek

  • platform changed from win32 to all
  • summary changed from Crash on Windows to Crash on parsing unknown command line arguments.

Hello.

Thanks for report. Few things:

1. This is not Win32 specific. 2. Crash caused by code similar to fixed in r43876.

If someone have time to switch Parrot_ex_throw_from_c into "do_panic" it will fix this issue.

-- Bacek

Changed 4 years ago by fperrad

s/Parrot_snprintf/snprintf/g; and remove interp

Changed 4 years ago by fperrad

Interp isn't initialized yet. So remove it. See fix_longopt.patch

Changed 4 years ago by bacek

  • status changed from new to closed
  • resolution set to fixed

Finally fixed in r43947.

Note: See TracTickets for help on using tickets.