Ticket #1440 (closed bug: wontfix)

Opened 5 years ago

Last modified 5 years ago

parrot-nqp does not parse { in string correctly

Reported by: Austin_Hastings Owned by:
Priority: normal Milestone:
Component: none Version: 2.0.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

austin@andLinux:~/kakapo$ cat test.nqp
my $test := "{\n";
austin@andLinux:~/kakapo$ parrot-nqp test.nqp
Unable to parse blockoid, couldn't find final '}' at line 1
current instr.: 'parrot;Regex;Cursor;FAILGOAL' pc 1664 (src/stage0/Regex-s0.pir:907)
called from Sub 'parrot;NQP;Grammar;blockoid' pc 9148 (src/stage0/NQP-s0.pir:2561)
called from Sub 'parrot;NQP;Grammar;block' pc 8809 (src/stage0/NQP-s0.pir:2483)
called from Sub 'parrot;NQP;Grammar;quote_escape:sym<{ }>' pc 37754 (src/stage0/NQP-s0.pir:9638)
called from Sub 'parrot;Regex;Cursor;!protoregex' pc 1752 (src/stage0/Regex-s0.pir:971)
called from Sub 'parrot;HLL;Grammar;quote_escape' pc 9583 (src/stage0/HLL-s0.pir:2943)
called from Sub 'parrot;HLL;Grammar;quote_atom' pc 4900 (src/stage0/HLL-s0.pir:1751)
called from Sub 'parrot;HLL;Grammar;quote_delimited' pc 4514 (src/stage0/HLL-s0.pir:1648)
called from Sub 'parrot;HLL;Grammar;quote_EXPR' pc 698 (src/stage0/HLL-s0.pir:417)
called from Sub 'parrot;NQP;Grammar;quote:sym<dblq>' pc 35665 (src/stage0/NQP-s0.pir:9083)
called from Sub 'parrot;Regex;Cursor;!protoregex' pc 1752 (src/stage0/Regex-s0.pir:971)
called from Sub 'parrot;NQP;Grammar;quote' pc 35382 (src/stage0/NQP-s0.pir:9002)
called from Sub 'parrot;NQP;Grammar;value' pc 34641 (src/stage0/NQP-s0.pir:8816)
called from Sub 'parrot;NQP;Grammar;term:sym<value>' pc 34403 (src/stage0/NQP-s0.pir:35)
called from Sub 'parrot;Regex;Cursor;!protoregex' pc 1752 (src/stage0/Regex-s0.pir:971)
called from Sub 'parrot;NQP;Grammar;term' pc 32472 (src/stage0/NQP-s0.pir:8312)
called from Sub 'parrot;HLL;Grammar;termish' pc 2350 (src/stage0/HLL-s0.pir:1040)
called from Sub 'parrot;HLL;Grammar;EXPR' pc 1016 (src/stage0/HLL-s0.pir:552)
called from Sub 'parrot;NQP;Grammar;statement' pc 6623 (src/stage0/NQP-s0.pir:1943)
called from Sub 'parrot;NQP;Grammar;statementlist' pc 6147 (src/stage0/NQP-s0.pir:1807)
called from Sub 'parrot;NQP;Grammar;comp_unit' pc 5828 (src/stage0/NQP-s0.pir:36)
called from Sub 'parrot;NQP;Grammar;TOP' pc 1020 (src/stage0/NQP-s0.pir:390)
called from Sub 'parrot;Regex;Cursor;parse' pc 282 (src/stage0/Regex-s0.pir:181)
called from Sub 'parrot;HLL;Compiler;parse' pc 5 (src/stage0/HLL-s0.pir:24)
called from Sub 'parrot;PCT;HLLCompiler;compile' pc 388 (src/PCT/HLLCompiler.pir:287)
called from Sub 'parrot;PCT;HLLCompiler;eval' pc 992 (src/PCT/HLLCompiler.pir:556)
called from Sub 'parrot;PCT;HLLCompiler;evalfiles' pc 1303 (src/PCT/HLLCompiler.pir:707)
called from Sub 'parrot;PCT;HLLCompiler;command_line' pc 1489 (src/PCT/HLLCompiler.pir:794)
called from Sub 'parrot;NQP;Compiler;main' pc -1 ((unknown file):-1)

Change History

Changed 5 years ago by Austin_Hastings

  • status changed from new to closed
  • resolution set to wontfix

Aha! This is related to interpolating {...} closures in qq strings. Not a bug, since the interpolation really did fail because of no closing block. Just a place for a better error message.

Note: See TracTickets for help on using tickets.