Ticket #151 (closed bug: fixed)

Opened 6 years ago

Last modified 6 years ago

t/pmc/exceptionhandler.t: File terminates early without explanation, disrupting plan

Reported by: jkeenan Owned by:
Priority: normal Milestone:
Component: core Version: trunk
Severity: medium Keywords: exceptionhandler plan
Cc: Language:
Patch status: Platform: linux

Description

Running make smoldertest on Linux at r35324 tonight, I got this one test failure (see first attachment). Note that there is no explanation as to why tests 7 and 8 failed to run.

When I checked the  uploaded Smolder report for this file, I saw something very peculiar (second attachment). Even though the plan specifically calls for 8 tests, only 6 complete -- yet the file displays on Smolder as a 100% pass.

I wonder if the fact that some tests are in a subroutine invoked by a gotoo could have confused the plan count.

53:    goto more_tests
54-
55-  nonfatal_handler_one:
56-    .local pmc e, c
57-    .get_results (e)
58-    ok(1, 'Min and Max severity for exception handlers')
--
70:  more_tests:
71-
72-    eh = new ['ExceptionHandler']
73-    set_addr eh, typed_handler_one
74-    eh.'handle_types'(.CONTROL_OK, .CONTROL_BREAK)
75-    push_eh eh

There are other recent Smolder reports (on FreeBSD, for instance) where the file DWIMs, i.e., it runs the full 8 tests but reports one as skipped.

Can anyone shed any light on what's going on?

Thank you very much.
kid51

Attachments

t.pmc.exceptionhandlers.t.failure.txt Download (0.6 KB) - added by jkeenan 6 years ago.
t/pmc/exceptionhandler.t: Early unexplained failure
smolder.difference.between.plan.and.count.txt Download (365 bytes) - added by jkeenan 6 years ago.
Smolder report showing 8 tests planned, only 6 run, but no explanation of failure

Change History

Changed 6 years ago by jkeenan

t/pmc/exceptionhandler.t: Early unexplained failure

Changed 6 years ago by jkeenan

Smolder report showing 8 tests planned, only 6 run, but no explanation of failure

  Changed 6 years ago by jkeenan

See also TT #154.

in reply to: ↑ description   Changed 6 years ago by jkeenan

  • status changed from new to closed
  • resolution set to fixed

Replying to jkeenan:

Running make smoldertest on Linux at r35324 tonight, I got this one test failure (see first attachment). Note that there is no explanation as to why tests 7 and 8 failed to run.

Well, something got fixed. As of r35476, the problem is no longer occuring on the system where I noticed it:

1..8
ok 1 - Instantiated ExceptionHandler
ok 2 - Min and Max severity for exception handlers
ok 3 - Min and Max severity for exception handlers
ok 4 - Exception Handler type checks work
ok 5 - Exception Handler type checks work
ok 6 - Exception Handler subclass popped
ok 7 - Exception Handler subclass with can_handle method catch exception
ok 8 #skip Exception Handler subclass causes segfault

Anyone want to take credit for fixing it?

kid51

Note: See TracTickets for help on using tickets.