Ticket #1528 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Continuations still interact badly with .return

Reported by: arnsholt Owned by:
Priority: normal Milestone:
Component: none Version: trunk
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: darwin

Description

Related to #1521. It seems that the issue as reported is fixed, but if the .tailcall directive is removed, the bug reappears. I'll attach a patch to the test file as soon as I've got the TT number.

Attachments

conttest.patch Download (1.8 KB) - added by arnsholt 4 years ago.
Patch for test file. Created with svn diff at the parrot root.
conttest2.patch Download (1.8 KB) - added by whiteknight 4 years ago.
fix to the test

Change History

Changed 4 years ago by arnsholt

Patch for test file. Created with svn diff at the parrot root.

Changed 4 years ago by whiteknight

fix to the test

Changed 4 years ago by whiteknight

I've just attached a second version of the patch that "fixes" the test. In the two tests the behavior was different. When the do_tailcall variable is 0, we call choose, ignore the return value from it, then fall through to the next label and tailcall choose. Fixing the semantics so they do the same thing both times, the test passes.

So the question is whether the "problem" is resolved, or whether the test simply doesn't exercise the problem.

Changed 4 years ago by arnsholt

This is not the bug you are looking for. Problem caused by bad code on my end. Can be closed.

Changed 4 years ago by whiteknight

  • status changed from new to closed
  • resolution set to fixed

closing

Note: See TracTickets for help on using tickets.