Ticket #1562 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

Silence Configure.pl warnings about ccwarn when the default compiler is not gcc

Reported by: doughera Owned by: coke
Priority: normal Milestone:
Component: configure Version: 2.2.0
Severity: low Keywords:
Cc: Language:
Patch status: applied Platform:

Description

As of r45800, Configure.pl issues many warnings about undefined variables if the default compiler is used and it is not gcc. The root cause is that config/init/defaults.pm tries to load perl5's $Config{ccwarn}, but perl5's Configure does not define any such variable. Hence ccwarn gets set to undef, which leads to lots of warnings later on. The attached patch fixes the problem by always setting the default value of ccwarn to ''

Attachments

ccwarn-undef.patch Download (0.8 KB) - added by doughera 5 years ago.

Change History

Changed 5 years ago by doughera

Changed 5 years ago by coke

  • owner set to coke
  • patch changed from new to applied

Good catch. Snuck it in as r45809 before the 2.3.0 release.

Changed 5 years ago by coke

  • status changed from new to closed
  • resolution set to fixed

(for those who are just reading the ticket, this was probably not introduced in r45800, just noticed then.)

Note: See TracTickets for help on using tickets.