Ticket #1614 (closed todo: fixed)

Opened 5 years ago

Last modified 4 years ago

t/pmc/packfile.t: implement todo-ed item: pack produced same result twice

Reported by: jkeenan Owned by: NotFound
Priority: normal Milestone:
Component: core Version: 2.3.0
Severity: medium Keywords:
Cc: bacek Language:
Patch status: Platform:

Description

Creating a ticket to track this todo-ed item:

t/pmc/packfile.t-316-    $I0 = not $I0
t/pmc/packfile.t:317:    todo($I0, 'pack produced same result twice')
t/pmc/packfile.t-318-    .return()

Note: This has been passing for me on Linux/i386 since approx r46154 on 20100429. However, it continues to fail on Darwin/PPC.

Change History

  Changed 5 years ago by jkeenan

  • type changed from bug to todo

  Changed 5 years ago by NotFound

It fails also on x64.

Part of the problem is that it unpacks a pbc generated on i386, then repack it, giving a native one, and then compares, Obviously this passes only on architectures and configurations very close to i386.

In addition, I think there is a problem with segment ordering, and maybe some padding is done with random garbage instead of zeroes.

  Changed 5 years ago by bacek

Hello.

I've added this test during implementation of Packfile PMCs. It's actually "wish" test to have single PBC format (and can be removed...).

follow-up: ↓ 5   Changed 4 years ago by NotFound

  • owner set to NotFound

The test message says "pack produced same result twice", so I modified it to do just that, packing two times and comparing the results of both packs, ignoring the one loaded from the pbc. That solves the problem while still testing something.

Done and untodoed the test in r47475. Tested in i386 and amd64, keep the ticket open a few days to wait for results in other platforms.

in reply to: ↑ 4   Changed 4 years ago by jkeenan

Replying to NotFound:

Tested in i386 and amd64, keep the ticket open a few days to wait for results in other platforms.

Tested satisfactorily at r47499 on linux/i386 and darwin/ppc. Thanks for your attention to this problem.

kid51

  Changed 4 years ago by NotFound

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.