Ticket #1646 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

Failure due to missing external definition of inlined function Parrot_str_rep_compatible

Reported by: doughera Owned by:
Priority: normal Milestone:
Component: none Version: 2.3.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

Using Sun's compiler on Linux, with r46743, the build fails with the following error message:

/dev/shm/parrot/blib/lib/libparrot.so: undefined reference to `Parrot_str_rep_compatible'

The problem is that src/string/api.c defines Parrot_str_rep_compatible as "inline static", but the function is also referred to in /src/pmc/stringbuilder.pmc.

For the inlined function to be available for external linking, it should be declared as "extern inline." (This is assuming that this particular function should be inline.)

Change History

Changed 5 years ago by bacek

  • status changed from new to closed
  • resolution set to fixed

Fixed in r46749. Thanks!

Note: See TracTickets for help on using tickets.