Ticket #1669 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

t/pmc/eval.t and t/pmc/threads.t fail during 'make coretest'

Reported by: coke Owned by:
Priority: major Milestone:
Component: none Version: trunk
Severity: high Keywords:
Cc: Language:
Patch status: Platform:

Description

at r47253.

Looks like yet more fallout from the ops_massacre.

$  prove -v t/pmc/eval.t  t/pmc/threads.t
#   Failed test 'eval.freeze+thaw'
#   at t/pmc/eval.t line 424.
# Exited with error code: 1
# Received:
# error:imcc:syntax error, unexpected VAR, expecting '(' ('file')
#       in file '/Users/coke/sandbox/parrot/t/pmc/eval_13.pir' line 44
# error:imcc:syntax error, unexpected VAR, expecting '(' ('io')
#       in file '/Users/coke/sandbox/parrot/t/pmc/eval_13.pir' line 46
# error:imcc:syntax error ... somewhere
#       in file '/Users/coke/sandbox/parrot/t/pmc/eval_13.pir' line 51
#
# Expected:
# written
# hello from foo_1
# hello from foo_1
#
# Looks like you failed 1 test of 17.
t/pmc/eval.t .....
1..17
ok 1 - eval_sc
ok 2 - call subs in evaled code
ok 3 - call 2 subs in evaled code
ok 4 - PIR compiler sub
ok 5 - bug \#31467
ok 6 - PIR compiler sub PASM
ok 7 - PIR compiler sub PIR
ok 8 - eval.get_string
ok 9 - check loaded lib hash
ok 10 - eval.get_string - same file
ok 11 - eval.freeze
not ok 12 - eval.thaw # TODO TT #1142


#   Failed (TODO) test 'eval.thaw'
#   at t/pmc/eval.t line 401.
# Exited with error code: 1
# Received:
# error:imcc:syntax error, unexpected VAR, expecting '(' ('file')

# error:imcc:syntax error, unexpected VAR, expecting '(' ('io')
#       in file '/Users/coke/sandbox/parrot/t/pmc/eval_12.pir' line 10
# error:imcc:syntax error ... somewhere
#       in file '/Users/coke/sandbox/parrot/t/pmc/eval_12.pir' line 16
#
# Expected:
# hello from foo_1
# hello from foo_1
#
not ok 13 - eval.freeze+thaw
ok 14 - get_pmc_keyed_int
ok 15 - catch compile err
ok 16 - compile err in load_bytecode
ok 17 - catch compile err in load_bytecode
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/17 subtests

#   Failed test 'CLONE_CODE|CLONE_GLOBALS|CLONE_HLL|CLONE_LIBRARIES - TT \# 1250'
#   at t/pmc/threads.t line 829.
# Exited with error code: 1
# Received:
# Class '[ 'Foo' ]' not found
# current instr.: 'main' pc 82 (/Users/coke/sandbox/parrot/t/pmc/threads_14.pir:46)
#
# Expected:
# in thread:
# 0
# ok (equal)
# 42
# in main:
# 0
# ok (equal)
# 42
#
# Looks like you failed 1 test of 14.

t/pmc/threads.t ..
1..14
ok 1 - interp identity
ok 2 - thread type 1
ok 3 - thread type 1 -- repeated
ok 4 - thread type 2
ok 5 - thread - kill
ok 6 - join, get retval
ok 7 - sub name lookup in new thread
ok 8 - CLONE_CODE only
ok 9 - CLONE_CODE | CLONE_GLOBALS
not ok 10 - CLONE_CODE | CLONE_CLASSES; superclass not built-in # TODO vtable overrides aren't properly cloned TT # 1248
#   Failed (TODO) test 'CLONE_CODE | CLONE_CLASSES; superclass not built-in'
#   at t/pmc/threads.t line 452.
#          got: 'in thread:
# A Bar
# called Bar's barmeth
# called Foo's foometh
# Integer? 0
# Foo? 0
# Bar? 1
# in main:
# A Bar
# called Bar's barmeth
# called Foo's foometh
# Integer? 0
# Foo? 1
# Bar? 1
# '
#     expected: 'in thread:
# A Bar
# called Bar's barmeth
# called Foo's foometh
# Integer? 0
# Foo? 1
# Bar? 1
# in main:

# A Bar
# called Bar's barmeth
# called Foo's foometh
# Integer? 0
# Foo? 1
# Bar? 1
# '
not ok 11 - CLONE_CODE | CLONE_CLASSES; superclass built-in # TODO likely incorrect test TT 1248
#   Failed (TODO) test 'CLONE_CODE | CLONE_CLASSES; superclass built-in'
#   at t/pmc/threads.t line 537.
#          got: 'in thread:
# A Bar
# called Bar's barmeth
# called Foo's foometh
# Integer? 1
# Foo? 0
# Bar? 1
# in main:
# A Bar
# called Bar's barmeth
# called Foo's foometh
# Integer? 1
# Foo? 1
# Bar? 1
# '
#     expected: 'in thread:
# A Bar
# called Bar's barmeth
# called Foo's foometh
# Integer? 1
# Foo? 1
# Bar? 1
# in main:
# A Bar
# called Bar's barmeth
# called Foo's foometh
# Integer? 1

# Foo? 1
# Bar? 1
# '
ok 12 - CLONE_CODE | CLONE_GLOBALS| CLONE_HLL
ok 13 - globals + constant table subs issue
not ok 14 - CLONE_CODE|CLONE_GLOBALS|CLONE_HLL|CLONE_LIBRARIES - TT \# 1250
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/14 subtests

Test Summary Report
-------------------
t/pmc/eval.t   (Wstat: 256 Tests: 17 Failed: 1)
  Failed test:  13
  Non-zero exit status: 1
t/pmc/threads.t (Wstat: 256 Tests: 14 Failed: 1)
  Failed test:  14
  Non-zero exit status: 1
Files=2, Tests=31,  6 wallclock secs ( 0.05 usr  0.01 sys +  1.36 cusr  0.42 csys =  1.84 CPU)
Result: FAIL

Change History

Changed 4 years ago by jkeenan

Changed 4 years ago by mikehh

These tests now pass in make corevm/make coretest

If there is no objection I will close this ticket in the next 24 hours.

Changed 4 years ago by jkeenan

Confirmed on linux/i386. Confirmed on darwin/ppc.

Changed 4 years ago by mikehh

  • status changed from new to closed
  • resolution set to fixed

Closing this ticket

All tests PASS (pre/post-config, make corevm/make coretest, smoke (#34306), fulltest) at r47544 - Ubuntu 10.04 i386 (g++ with --optimize)

and all other platforms/options that I am aware of

Note: See TracTickets for help on using tickets.