Ticket #1688 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Internal assertion triggered when writing trivial code.

Reported by: shockwave Owned by:
Priority: major Milestone:
Component: core Version: 2.5.0
Severity: high Keywords: assertion
Cc: Language:
Patch status: Platform:

Description

.sub 'foobar'
.end

.sub '' :immediate
  'foobar'()
.end

##### ASSERTION MESSAGE ###### # src/runcore/cores.c:635: failed assertion 'pc'

Change History

Changed 4 years ago by NotFound

Replacing the call to foobar with:

  $P1 = find_sub_not_null 'foobar'
  $P1()

It works. So looks like the problem is that the const sub generated by imcc for the call is not initialized at immediate calls point.

Changed 3 years ago by Felipe

  • status changed from new to closed
  • resolution set to fixed

I can not reproduce this issue. It seems already fixed.

Note: See TracTickets for help on using tickets.