Ticket #1703 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

IMCC doesn't generate get_params op for argless subs.

Reported by: bacek Owned by:
Priority: normal Milestone:
Component: imcc Version: trunk
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

Hello.

IMCC doesn't generate get_params for argless sub which leads to buggy code.

E.g.

$ cat t.pir
.sub "foo"
    say "foo"
.end

.sub "main" :main
    say "Hello, World"
    "foo"("bar")
.end

$ parrot t.pir 
Hello, World
foo

This should throw exception too many positional arguments: 1 passed, 0 expected

-- Bacek

Change History

Changed 4 years ago by pmichaud

On Tue, Jul 06, 2010 at 10:19:10PM -0000, Parrot wrote:
> #1703: IMCC doesn't generate get_params op for argless subs.
> 
>  IMCC doesn't generate get_params for argless sub which leads to buggy
>  code.

Note that this ticket is a duplicate of
http://trac.parrot.org/parrot/ticket/1033, which itself was forwarded
from RT# 39844.

Pm

Changed 4 years ago by bacek

  • status changed from new to closed
  • resolution set to duplicate

Oh... I have to use search before creating tickets... Marking as "duplicate".

-- Bacek

Note: See TracTickets for help on using tickets.