Ticket #1722 (closed bug: fixed)

Opened 4 years ago

Last modified 3 years ago

osx build failed caused by errant '\c'

Reported by: LaVolta Owned by: jkeenan
Priority: normal Milestone:
Component: build Version: 2.6.0
Severity: medium Keywords: osx build icu
Cc: Language:
Patch status: applied Platform: mac

Description

OS:

Darwin mac.local 10.4.0 Darwin Kernel Version 10.4.0: Fri Apr 23 18:28:53 PDT 2010; root:xnu-1504.7.4~1/RELEASE_I386 i386 i386


Error message:

perl -MExtUtils::Command -e mkpath blib/lib
c++ -dynamiclib -undefined dynamic_lookup -L/usr/local/lib -L/Users/horus/.test/src/parrot/blib/lib -L/opt/local/lib  -o blib/lib/libparrot.2.6.0.dylib -install_name /Users/horus/.test/src/parrot/blib/lib/libparrot.dylib \
                src/string/api.o src/ops/core_ops.o src/byteorder.o src/string/charset.o src/core_pmcs.o src/datatypes.o src/debug.o src/dynext.o src/embed.o src/string/encoding.o src/exceptions.o src/exit.o src/extend.o src/extend_vtable.o src/gc/alloc_memory.o src/gc/api.o src/gc/gc_ms.o src/gc/gc_inf.o src/gc/mark_sweep.o src/gc/system.o src/global_setup.o src/hash.o src/hll.o src/call/pcc.o src/call/args.o src/interp/inter_cb.o src/interp/inter_create.o src/interp/inter_misc.o src/call/ops.o src/call/context.o src/call/context_accessors.o src/key.o src/library.o src/longopt.o src/misc.o src/multidispatch.o src/namespace.o src/frame_builder.o src/nci/api.o src/nci/core_thunks.o src/nci/extra_thunks.o src/oo.o src/packfile.o src/packout.o src/platform.o src/pmc_freeze.o src/pmc.o src/runcore/main.o src/runcore/cores.o src/runcore/profiling.o src/scheduler.o src/spf_render.o src/spf_vtable.o src/string/primitives.o src/sub.o src/thread.o src/runcore/trace.o src/utils.o src/vtables.o src/warnings.o src/packfile/pf_items.o src/gc/alloc_resources.o  src/string/charset/ascii.o src/string/charset/binary.o src/string/charset/iso-8859-1.o src/string/charset/tables.o src/string/charset/unicode.o src/io/core.o src/io/api.o src/io/utf8.o src/io/buffer.o src/io/unix.o src/io/win32.o src/io/portable.o src/io/filehandle.o src/io/socket_api.o src/io/socket_unix.o src/io/socket_win32.o src/pmc/default.o src/pmc/null.o src/pmc/env.o src/pmc/key.o src/pmc/unmanagedstruct.o src/pmc/managedstruct.o src/pmc/exception.o src/pmc/parrotlibrary.o src/pmc/parrotinterpreter.o src/pmc/parrotthread.o src/pmc/lexpad.o src/pmc/timer.o src/pmc/pointer.o src/pmc/sub.o src/pmc/continuation.o src/pmc/coroutine.o src/pmc/eval.o src/pmc/nci.o src/pmc/float.o src/pmc/integer.o src/pmc/bigint.o src/pmc/bignum.o src/pmc/complex.o src/pmc/string.o src/pmc/boolean.o src/pmc/fixedintegerarray.o src/pmc/iterator.o src/pmc/fixedstringarray.o src/pmc/hash.o src/pmc/orderedhash.o src/pmc/oplib.o src/pmc/opcode.o src/pmc/addrregistry.o src/pmc/arrayiterator.o src/pmc/bytebuffer.o src/pmc/callcontext.o src/pmc/capture.o src/pmc/class.o src/pmc/codestring.o src/pmc/eventhandler.o src/pmc/exceptionhandler.o src/pmc/exporter.o src/pmc/filehandle.o src/pmc/fixedbooleanarray.o src/pmc/fixedfloatarray.o src/pmc/fixedpmcarray.o src/pmc/handle.o src/pmc/hashiterator.o src/pmc/hashiteratorkey.o src/pmc/imageio.o src/pmc/imageiosize.o src/pmc/imageiostrings.o src/pmc/lexinfo.o src/pmc/multisub.o src/pmc/namespace.o src/pmc/object.o src/pmc/orderedhashiterator.o src/pmc/packfile.o src/pmc/packfileannotation.o src/pmc/packfileannotations.o src/pmc/packfileconstanttable.o src/pmc/packfiledebug.o src/pmc/packfiledirectory.o src/pmc/packfilefixupentry.o src/pmc/packfilefixuptable.o src/pmc/packfilerawsegment.o src/pmc/packfilesegment.o src/pmc/pmcproxy.o src/pmc/resizablebooleanarray.o src/pmc/resizablefloatarray.o src/pmc/resizableintegerarray.o src/pmc/resizablepmcarray.o src/pmc/resizablestringarray.o src/pmc/role.o src/pmc/scalar.o src/pmc/scheduler.o src/pmc/schedulermessage.o src/pmc/sockaddr.o src/pmc/socket.o src/pmc/stringbuilder.o src/pmc/stringhandle.o src/pmc/stringiterator.o src/pmc/task.o src/pmc/threadinterpreter.o src/pmc/undef.o src/string/encoding/fixed_8.o src/string/encoding/ucs2.o src/string/encoding/ucs4.o src/string/encoding/utf16.o src/string/encoding/utf8.o compilers/imcc/imcparser.o compilers/imcc/imclexer.o compilers/imcc/imc.o compilers/imcc/main.o compilers/imcc/symreg.o compilers/imcc/instructions.o compilers/imcc/cfg.o compilers/imcc/reg_alloc.o compilers/imcc/sets.o compilers/imcc/debug.o compilers/imcc/optimizer.o compilers/imcc/pbc.o compilers/imcc/parser_util.o compilers/imcc/pcc.o -lm -lutil -lgmp -lreadline -lintl -lpthread -lm   -L/opt/local/lib  -licuuc -licudata  -lpthread -lm  \c 
i686-apple-darwin10-g++-4.2.1: c: No such file or directory
make: *** [blib/lib/libparrot.2.6.0.dylib] Error 1


the old work-around not work any more. patched included, tested locally, worked, though it's ugly...

Attachments

parrot-icu.patch Download (394 bytes) - added by LaVolta 4 years ago.
my humble patch

Change History

Changed 4 years ago by LaVolta

my humble patch

follow-up: ↓ 2   Changed 4 years ago by NotFound

  • patch set to applied

Applied in r48227, thanks.

in reply to: ↑ 1   Changed 4 years ago by jkeenan

Replying to NotFound:

Applied in r48227, thanks.

Would that take care of TT #890 as well?

kid51

  Changed 4 years ago by NotFound

  • status changed from new to closed
  • resolution set to fixed

After 3 weeks without complaints, closing ticket.

  Changed 3 years ago by jkeenan

  • status changed from closed to reopened
  • resolution fixed deleted

Reopened per post by Tom Christiansen on  parrot-dev.

    $icushared =~ s/\s\\c\s/ /g;

That isn't good enough, because some of the strings you do that to actually *end* in " \\c", so there is no whitespace following. Therefore you need something more like

    $icushared =~ s/\s\\c\s?/ /g;

At which point all builds fine. Until then, it fails.

  Changed 3 years ago by jkeenan

  • owner set to jkeenan
  • status changed from reopened to new

Correction applied in 351378a. Can we get some test reports on various OSes? In particular, various flavors of Darwin?

Also, please run perl Configure.pl --test=build.

Thank you very much.

kid51

  Changed 3 years ago by jkeenan

  • status changed from new to assigned

  Changed 3 years ago by jkeenan

  • status changed from assigned to closed
  • resolution set to fixed

No complaints heard. Closing ticket.

Note: See TracTickets for help on using tickets.