Ticket #1762 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Memory leak in Parrot_find_method_with_cache

Reported by: nwellnhof Owned by:
Priority: normal Milestone:
Component: core Version: trunk
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

$ ./parrot -o tmp2.pbc t/compilers/pge/pge_text_5.pir
$ valgrind --leak-check=full ./parrot tmp2.pbc
==9708== Memcheck, a memory error detector
==9708== Copyright (C) 2002-2010, and GNU GPL'd, by Julian Seward et al.
==9708== Using Valgrind-3.6.0.SVN-Debian and LibVEX; rerun with -h for copyright info
==9708== Command: ./parrot tmp2.pbc
==9708==
failed==9708==
==9708== HEAP SUMMARY:
==9708==     in use at exit: 1,522,965 bytes in 835 blocks
==9708==   total heap usage: 17,604 allocs, 16,769 frees, 2,768,608 bytes allocated
==9708==
==9708== 12 bytes in 1 blocks are definitely lost in loss record 9 of 464
==9708==    at 0x402328F: calloc (vg_replace_malloc.c:467)
==9708==    by 0x4087E89: gc_ms_allocate_memory_chunk_zeroed (gc_ms.c:1415)
==9708==    by 0x4086E58: Parrot_gc_allocate_memory_chunk_with_interior_pointers (api.c:660)
==9708==    by 0x40B1685: Parrot_find_method_with_cache (oo.c:1016)
==9708==    by 0x40CE6AA: Parrot_default_find_method (default.pmc:568)
==9708==    by 0x408C71E: Parrot_pcc_invoke_method_from_c_args (pcc.c:201)
==9708==    by 0x411D99D: Parrot_CodeString_nci_key (codestring.pmc:513)
==9708==    by 0x40E16FC: Parrot_NCI_invoke (nci.pmc:396)
==9708==    by 0x406A1C5: Parrot_callmethodcc_p_sc (core_ops.c:19793)
==9708==    by 0x40BB0B4: runops_slow_core (cores.c:647)
==9708==    by 0x40BA9CD: runops_int (main.c:237)
==9708==    by 0x40903FC: runops (ops.c:127)
==9708==

Change History

Changed 4 years ago by nwellnhof

I can't reproduce the leak with r48795.

Changed 4 years ago by nwellnhof

  • status changed from new to closed
  • resolution set to fixed

I can't reproduce the leak with r48953 either. Closing.

Note: See TracTickets for help on using tickets.