Ticket #1773 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

make headerizer fails on Windows XP

Reported by: Paul C. Anagnostopoulos Owned by: Paul C. Anagnostopoulos
Priority: normal Milestone:
Component: build Version: 2.6.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: win32

Description

While attempting to make headerizer today, I got the following error:

can't find HEADERIZER HFILE directive in "src/ops/core_ops.c" at tools/dev/headerizer.pl line 355.
mingw32-make: *** [headerizer] Error 255

Evan after a make realclean, reconfigure, and make, the problem persists.

I am running on 32-bit Windows XP. Just in case it had something to do with what I was working on, NotFound applied a patch to replicate my work and then tried headerizing on his linux amd64 system. He had no problem.

Could other Windows developers try a make headerizer and report the results?

Change History

Changed 4 years ago by Paul C. Anagnostopoulos

  • status changed from new to assigned
  • owner set to Paul C. Anagnostopoulos

Changed 4 years ago by Paul C. Anagnostopoulos

  • status changed from assigned to closed
  • resolution set to fixed

Okay, the problem is in headerizer.pl. It skips files in 'src/ops' by matching with the local directory separator character. But on Windows you can use either \ or /, so it needs to match with the local character or a slash. Now it does.

Thanks to everyone on #parrot for helping to track this down. Fixed in r48887 and ticket closed.

Note: See TracTickets for help on using tickets.