Ticket #1776 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

r48847 breaks Rakudo

Reported by: moritz Owned by:
Priority: major Milestone:
Component: none Version: 2.6.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

Starting from parrot r48847, Rakudo has multiple spectest failures.

For example

   make t/spec/S32-list/reduce.t

aborts with

can't get class from an instance of class 'P6role' in 'Test::isa_ok' at line 142:Test.pm in main program body at line 61:t/spec/S32-list/reduce.rakudo

Change History

Changed 4 years ago by pmichaud

On Wed, Sep 08, 2010 at 07:42:57PM -0000, Parrot wrote:
>  For example
> 
>  {{{
>     make t/spec/S32-list/reduce.t
>  }}}
> 
>  aborts with
> 
>  {{{
>  can't get class from an instance of class 'P6role' in 'Test::isa_ok' at
>  line 142:Test.pm in main program body at line
>  61:t/spec/S32-list/reduce.rakudo
>  }}}

This was ultimately caused by r48851, which changed the internals
of how get_class works.  cotto++ reverted the functional bits of
this in r48899, and Rakudo passes spectests again.

(For reference, between r48768 to r48909 there were at least three independent 
sets of Parrot core changes that were causing Rakudo to either not build on 
64-bit systems or to fail its spectests.  So in that range it's often hard
to pinpoint exactly which commit led to a breakage.)

There is discussion that the change that was made in r48851 will be
reapplied after a suitable deprecation period, so we may still need to
figure out what broke here.  Until then, resolving this ticket as fixed.

Thanks!

Pm

Changed 4 years ago by pmichaud

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.