Ticket #1779 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

test failures on OSX

Reported by: coke Owned by:
Priority: normal Milestone:
Component: none Version: trunk
Severity: medium Keywords:
Cc: wellnhofer@… Language:
Patch status: Platform: darwin

Description

Getting the following failures with vanilla "make test" on OS X

$ sw_vers 
ProductName:    Mac OS X
ProductVersion: 10.6.4
BuildVersion:   10F569
$ svn info | ack Revi
Revision: 48874
$ make -j3 realclean 
...
$ /Users/coke/usr/bin/perl Configure.pl --optimize --prefix=$HOME/bird \
  --cc="ccache gcc"
...
$ TEST_JOBS=4 make test
...
Test Summary Report
-------------------
t/compilers/pge/06-grammar.t              (Wstat: 11 Tests: 0 Failed: 0)
  Non-zero wait status: 11
  Parse errors: No plan found in TAP output
t/compilers/pge/perl6regex/01-regex.t     (Wstat: 0 Tests: 788 Failed: 3)
  Failed tests:  91, 555, 609
t/library/mime_base64.t                   (Wstat: 11 Tests: 0 Failed: 0)
  Non-zero wait status: 11
  Parse errors: Bad plan.  You planned 550 tests but ran 0.
Files=356, Tests=11901, 102 wallclock secs ( 3.97 usr  1.97 sys + 87.16 cusr 39.66 csys = 132.76 CPU)
Result: FAIL
make: *** [test_core] Error 1

Change History

Changed 4 years ago by nwellnhof

I suspect that the failure in t/library/mime_base64.t is caused by the charset_massacre merge. ash had the same problem and posted a backtrace [1] showing a crash in string_rep_compatible. The old string_rep_compatible didn't dereference the encoding pointers, so it's possible that there's a string with a NULL encoding pointer that the old code handled gracefully. Unfortunately, I don't have an OS X machine around, but I'm happy to work with anyone who does to track this issue down.

[1]  http://gist.github.com/570324

Changed 4 years ago by nwellnhof

  • cc wellnhofer@… added

Changed 4 years ago by NotFound

Check for null encoding in string_rep_compatible added in r48884

Changed 4 years ago by coke

Test still fails on r48892

Changed 4 years ago by coke

  • status changed from new to closed
  • resolution set to fixed

Issue was resolved in duplicate ticket #1783.

Note: See TracTickets for help on using tickets.