Ticket #1782 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

C++ build broken in r48923

Reported by: NotFound Owned by:
Priority: major Milestone:
Component: build Version: 2.7.0
Severity: high Keywords:
Cc: Language:
Patch status: Platform:

Description

C++ is broken at compiling core_ops.c

The problem is that the prototype for Parrot_DynOp_core_2_7_0 in include/parrot/oplib/core_ops.h does not match the definition in src/ops/core_ops.c: the prototype lacks the PARROT_EXPORT decorator and the declaration has it.

Compiling with C++ the PARROT_EXPORT expansion uses the linkage modifier 'extern "C"', thus the prototype and the definition don't match.

Change History

Changed 4 years ago by plobsing

  • status changed from new to closed
  • resolution set to fixed

Both declarations are now PARROT_EXPORT.

Note: See TracTickets for help on using tickets.