Ticket #1818 (closed bug: invalid)

Opened 4 years ago

Last modified 4 years ago

recent parrot change breaks a rakudo test

Reported by: moritz Owned by:
Priority: critical Milestone:
Component: core Version: 2.8.0
Severity: release Keywords:
Cc: Language: perl6
Patch status: Platform:

Description

A recent parrot change broke rakudo's t/spec/S11-modules/require.t test file.

It worked for sure in r49387, and fails on r49463.

My bisecting did not produce any reasonable results; even though I clean the parrot installation and do a realclean in both parrot and rakudo at each step, the response seems to be nearly always the same as the previous response, so it shows some kind of hysteresis. Weird.

Apart from that, the bug doesn't seems to be intermittent; repeated execution with the same rakudo+parrot build always gives the same result.

Change History

Changed 4 years ago by nwellnhof

Reduced test case:

$ ./perl6
> class B::Grammar {};
!class_init_64
> class B {};
Illegal redeclaration of symbol 'B'

It might have to do with my recent string macro changes. But it's strange that bisecting didn't show which commit caused the problem.

Changed 4 years ago by nwellnhof

Hmm, I justed tested r49387 and get the same error.

Nick

Changed 4 years ago by dukeleto

  • lang set to perl6
  • owner set to nwellnhof
  • component changed from none to core
  • severity changed from medium to release
  • priority changed from normal to critical

Nick:

Which commit do you suspect broke this?

Changed 4 years ago by cotto

I want to help fix this or at least narrow it down, but I get the same behavior with Rakudo builds as early as Sept 11 ( http://github.com/rakudo/rakudo/commit/8669d77a310a4675db8734e33969ac31db5977cd) and their associated Parrot version, and with Rakudo at HEAD and the latest Parrot from trunk.

Changed 4 years ago by nwellnhof

I think it's a Rakudo problem. The error occurs when using A.pm or B.pm from the test suite. All other tests that use these packages are disabled. Also, the require.t test seems to be pretty new.

Changed 4 years ago by nwellnhof

  • owner nwellnhof deleted

Changed 4 years ago by moritz

  • status changed from new to closed
  • resolution set to invalid

Sorry, I can't reproduce positive behaviour here, so it must have been my fault somewhere (maybe local modifications of the test or so).

Note: See TracTickets for help on using tickets.