Ticket #1836 (closed feature: fixed)

Opened 4 years ago

Last modified 3 years ago

Support non-ASCII characters in filenames

Reported by: nwellnhof Owned by:
Priority: normal Milestone:
Component: core Version: 2.10.0
Severity: medium Keywords:
Cc: jkeenan Language:
Patch status: Platform:

Description

Parrot has no support for non-ASCII characters in filenames. The filename passed to the system functions is the raw buffer content of a Parrot string regardless of its encoding.

UTF-8 on Linux works in most cases, but that's just luck.

Change History

Changed 4 years ago by coke

Can you provide a failing test case?

Changed 4 years ago by jkeenan

  • cc jkeenan added

In commit 05b2f96, on nwellnhof's advice, I TODO-ed a test of non-ASCII filenames due to inconsistent results.

Changed 3 years ago by NotFound

UnTODOed in d539bfb because the issue is fixed. Also, that test shouldn't be TODOed without a deprecation notice, is a feature being used, at least on linux.

Changed 3 years ago by nwellnhof

  • status changed from new to closed
  • resolution set to fixed

Fixed after merge of branch nwellnhof/unicode_dynpmcs

Note: See TracTickets for help on using tickets.