Ticket #1853 (closed deprecation: done)

Opened 3 years ago

Last modified 3 years ago

pkg-config support

Reported by: plobsing Owned by:
Priority: normal Milestone: 2.10
Component: none Version: 2.10.0
Severity: medium Keywords:
Cc: gerd Language:
Patch status: Platform:

Description

Due to the way it is installed, parrot.pc is not useful to anyone at the current time (TT #1842). Fixing it to be useful would violate the letter and the objectives of PDD30 (TT #735).

Also, itt is a duplicate configuration mechanism. it's existence muddiesthe waters when somebody wants to know how to build against parrot. Everyone should always be using parrot_config for anything parrot configuration related.

Change History

Changed 3 years ago by gerd

  • cc gerd added

Changed 3 years ago by plobsing

  • status changed from new to closed
  • resolution set to done

The generation and installation of parrot.pc has been removed. Deprecation complete.

Note: See TracTickets for help on using tickets.