Ticket #1861 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

ipv6 config probe too noisy

Reported by: coke Owned by: jkeenan
Priority: normal Milestone: 2.11
Component: configure Version: master
Severity: medium Keywords:
Cc: dukeleto Language:
Patch status: applied Platform:

Description

auto::ipv6 -          Determine IPV6 capabilities...Not OK - bind failed: Address family not supported by protocol family
.......................no.

A simple "no" should suffice.

Change History

Changed 4 years ago by jkeenan

  • cc dukeleto added
  • component changed from none to configure

Coke,

This was not due to any change in config/auto/ipv6.pm itself. However, yesterday the behavior of the C-probe was modified in commit 889d96d6.

commit 889d96d6085d0480f0f34916b8c9a5ba2e251f93
Author: Jonathan "Duke" Leto <jonathan@leto.net>
Date:   Sun Nov 21 12:40:13 2010 -0800

    Make ipv6 detection actually work, at least on Linux

So on Darwin, I'm getting the same noise you are.

Jonathan, can you look into this more?

Thank you very much.

kid51

Changed 4 years ago by jkeenan

  • owner set to jkeenan
  • status changed from new to assigned
  • patch set to applied

Please review commit 9509f35.

Thank you very much.

kid51

Changed 4 years ago by dukeleto

I modified the code so that it actually compiled. The noise has always been there, it is just bubbling up to the top now, since other things have been fixed.

Changed 4 years ago by jkeenan

  • status changed from assigned to closed
  • resolution set to fixed

No complaints; closing ticket.

Changed 4 years ago by coke

  • status changed from closed to reopened
  • resolution fixed deleted
The issue is not fixed, the probe is still complaining too verbosely.

Please reopen the ticket.

Changed 4 years ago by coke

  • status changed from reopened to closed
  • resolution set to fixed

Scratch that, was not testing against master-latest.

Issue is fixed, dukeleto++

Note: See TracTickets for help on using tickets.