Ticket #1871 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Rakudo randomly segfaults (probably GC related)

Reported by: moritz Owned by: bacek
Priority: normal Milestone: 2.11
Component: none Version: 2.10.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

Rakudo randomly segfaults some spectest files on parrot on amd64 linux, version RELEASE_2_10_1-477-gfa56f62, but works fine on RELEASE_2_10_1.

I suspect it's related to the recent GC branch merge(s), but I haven't really triaged it.

Change History

  Changed 4 years ago by nwellnhof

Confirmed on Linux/i386. I also guess it's caused by the latest GC changes.

  Changed 4 years ago by bacek

  • owner set to bacek

  Changed 4 years ago by bacek

Hello.

Root cause is same as in #1872. It should be fixed now. Can you retest please?

-- Bacek

follow-up: ↓ 5   Changed 4 years ago by nwellnhof

With be82239 I get even more random segfaults.

in reply to: ↑ 4   Changed 4 years ago by bacek

Replying to nwellnhof:

With be82239 I get even more random segfaults.

Can you try again on RELEASE_2_10_1-523-g2f60133?

-- Bacek.

  Changed 4 years ago by nwellnhof

Rakudo spectest passes with 8aa40c9 on Linux/i386.

Thanks, Nick

  Changed 4 years ago by bacek

Hello,

moritz can you retest please?

-- Bacek

  Changed 4 years ago by moritz

  • status changed from new to closed
  • resolution set to fixed

As of RELEASE_2_10_1-525-g8aa40c9 the segfault is gone. I guess bacek++ is to praise fo that.

Note: See TracTickets for help on using tickets.