Ticket #1876 (closed bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Should 'make clean' remove blib/ folder?

Reported by: fbrito Owned by: jkeenan
Priority: normal Milestone: 2.11
Component: build Version: 2.10.0
Severity: low Keywords:
Cc: Language:
Patch status: applied Platform: all

Description

Hello,

Is "make clean" supposed to remove blib/ folder? At the moment is not removing it.

 $ make
...
 $ make clean
...
 $ ls blib/lib/
libparrot.a  libparrot.so

"make realclean", on the other hand, removes blib/ folder with success.

Change History

  Changed 4 years ago by fbrito

(19:18:57) fbrito: interesting. it seems that make clean doesn't delete blib/lib/libparrot.a (19:22:31) fbrito: is that the expected behavior? should I mark that as a bug/try to make a patch? (19:25:12) Coke: that seems like something that clean should get (as opposed to realclean) (19:32:56) cotto_work: fbrito: looks like make clean isn't as clean as one would expect. Can you file a ticket? ... (19:51:30) cotto_work: fbrito: do you feel like fixing that bug?

  Changed 4 years ago by fbrito

Ops :)

(19:18:57) fbrito: interesting. it seems that make clean doesn't delete blib/lib/libparrot.a 
(19:22:31) fbrito: is that the expected behavior? should I mark that as a bug/try to make a patch? 
(19:25:12) Coke: that seems like something that clean should get (as opposed to realclean) 
(19:32:56) cotto_work: fbrito: looks like make clean isn't as clean as one would expect. Can you file a ticket? ... 
(19:51:30) cotto_work: fbrito: do you feel like fixing that bug?

  Changed 4 years ago by jkeenan

  • component changed from none to build
  • severity changed from medium to low

The rule of thumb which, IMO, we have always followed is:

make clean     -> removes that which is created by 'make'

make realclean -> removes that which is created by either 'perl Configure.pl' or 'make'

Based on that, I concur that make clean out to remove the blib/ directory.

Mis dos centavos.

kid51

follow-up: ↓ 5   Changed 4 years ago by fbrito

in reply to: ↑ 4   Changed 4 years ago by jkeenan

  • status changed from new to assigned
  • owner set to jkeenan
  • patch set to applied

Replying to fbrito:

I have made a patch:  https://github.com/parrot/parrot/pull/10#files_bucket

I simply re-typed the patch rather than do a git pull. I tested the patch and found it successful. I applied it in commit 31f6c2e. fbrito++

I will keep the ticket open for a few days for comments and complaints.

Thank you very much.

kid51

  Changed 4 years ago by jkeenan

No complaints received.

Another ticket closed via a contribution from a Google Code-In student. Thanks to Fernando Brito of  João Pessoa, Brasil.

Thank you very much.

kid51

  Changed 4 years ago by jkeenan

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.