Ticket #1878 (closed RFC: wontfix)

Opened 4 years ago

Last modified 4 years ago

Increase minimum perl 5 version to 5.10.0

Reported by: coke Owned by: cotto
Priority: normal Milestone: 2.11
Component: configure Version: 2.10.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

See: #1175

We are currently bundling the p5 Pod::Simple & Pod::Escapes in parrot. These modules became core in 5.9.3.

                 5.8.4         2004-Apr-21
                 5.9.3         2006-Jan-28

We could jump through hoops if necessary to keep our perl version stable and require versions of Pod::Simple, but this seems much simpler.

Change History

Changed 4 years ago by coke

  • summary changed from Increase minimum perl 5 version to 5.9.3 to Increase minimum perl 5 version to 5.10.0

Dukeleto++ pointed out that this means 5.10.0, as we don't want to rely on a dev release of p5.

        Rafael   5.10.0        2007-Dec-18

Changed 4 years ago by jkeenan

  • component changed from none to configure

Coke,

As you can probably guess, I'd love to go even farther and say: Perl 5.12.1 :-)

But already I can hear those voices in the distance whispering, " My Enterprisey distribution of Linux only provides Perl 5.8.x."

So this will probably require more discussion and signoff from the Architect and Project Manager.

kid51

Changed 4 years ago by cotto

I'm all for using modern software on machines under my control, but raising the requirement would exclude potential contributors who are either stuck with an ancient Perl or don't care to upgrade for whatever reason. I'm not above saying "tough luck" as we currently do to anyone running 5.6.x, but only if we have a sufficiently good reason to do so. A sufficiently good reason in this case would be that supporting 5.8.x causes us some kind of pain or holds back Parrot's development.

Using a bundled version of a core module isn't a big deal, and while it's nice to move code out of Parrot, the module also won't do any harm sitting there in its current state. Without a better reason my inclination is to reject this ticket.

Changed 4 years ago by pmichaud

Idle questions: What part(s) of Parrot require Pod::Simple and Pod::Escape? Are they needed to obtain "core" runtime functionality, or are they used to build documentation? If the latter, is it possible to keep the minimum Perl requirement at 5.8.x and require 5.10.x for people who are building those "non-core" parts of Parrot?

Pm

Changed 4 years ago by cotto

  • status changed from new to closed
  • resolution set to wontfix

I want to keep the same requirements for the build and the docs. We're already bundling Pod::Simple and Pod::Escapes, so I don't see much reason to change that now.

For the time being, I'm rejecting this ticket. We can revisit this issue later if supporting 5.8.x starts to cause us problems.

Note: See TracTickets for help on using tickets.