Ticket #1918 (closed RFC: duplicate)

Opened 3 years ago

Last modified 3 years ago

Remove share and share_ro VTABLEs

Reported by: Yuki`N Owned by:
Priority: normal Milestone:
Component: core Version: 2.10.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: all

Description

In my fork of parrot on github, I've created  an experimental branch to determine whether or not removing the share and share_ro VTABLEs have any effect on Parrot as a whole.

I've come up with the verdict that removing these virtually dead VTABLEs has no effect on the operation of Parrot itself, with all tests passing (make fulltest).

Further tests are recommended with Rakudo and other HLLs which build on master, but overall it seems like removal of these VTABLEs is a relatively simply dead code pruning.

Change History

Changed 3 years ago by Yuki`N

  • type changed from experimental to RFC

Changed 3 years ago by nwellnhof

  • status changed from new to closed
  • resolution set to duplicate

These vtables are used exclusively for threads, so this is basically a duplicate of #1920.

Note: See TracTickets for help on using tickets.