Ticket #1928 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

get_bool function of Rational dynpmc

Reported by: rfw Owned by:
Priority: normal Milestone:
Component: core Version: 2.11.0
Severity: high Keywords:
Cc: Language:
Patch status: Platform: all

Description

The Rational dynpmc is checked for truthfulness like so:

if (mpq_cmp_si(RT(SELF), 0, 0))

This means that the Rational requires a denominator of 0 to be false. This cannot possibly be a correct implementation.

Change History

Changed 4 years ago by cotto

  • status changed from new to closed
  • resolution set to duplicate

This looks like a dupe of #1965.

Note: See TracTickets for help on using tickets.