Ticket #1939 (closed bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

darwin: installed parrot linking to build directory

Reported by: jkeenan Owned by:
Priority: normal Milestone:
Component: install Version: 2.11.0
Severity: high Keywords:
Cc: Language:
Patch status: Platform: darwin

Description

As originally reported in  TT #1927, on Darwin an installed Parrot currently requires libraries found under the build directory. Implication: once you call make clean in the build directory, your installed Parrot fails with a message like this:

[pseudoinstall] 529 $ ./bin/parrot --version
dyld: Library not loaded: /Users/jimk/gitwork/parrot/blib/lib/libparrot.dylib
  Referenced from: /Users/jimk/work/pseudoinstall/./bin/parrot
  Reason: image not found
Trace/BPT trap

This basically renders Parrot unusable on this OS.

Attachments

darwin.libparrot_soname.diff Download (0.6 KB) - added by jkeenan 4 years ago.
Patch to make installed Parrot work even when build dir has been cleaned

Change History

Changed 4 years ago by coke

  • status changed from new to closed
  • resolution set to duplicate

Duplicate of #1890

Changed 4 years ago by jkeenan

Patch to make installed Parrot work even when build dir has been cleaned

Note: See TracTickets for help on using tickets.