Ticket #1948 (closed bug: worksforme)

Opened 11 years ago

Last modified 11 years ago

Configure with --no-line-directives still produces .c files filled with #line directives

Reported by: whiteknight Owned by:
Priority: normal Milestone:
Component: configure Version: master
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: linux

Description

It's my understanding that the --no-line-directives option to Configure.pl should produce .c files from the .pmc source files without #line directives. This is necessary for debugging, among other things. However when I try to debug in master with that option, I still have .c files filled with #line directives.

This happens for me on Linux-x64. I don't know if the related tools change on other platforms.

Change History

  Changed 11 years ago by jkeenan

Can you cite some .c files that showed up with these line directives in violation of your command-line option? (That might encourage others to start looking at this issue.)

Thank you very much.

kid51

in reply to: ↑ description   Changed 11 years ago by jkeenan

Replying to whiteknight:

It's my understanding that the --no-line-directives option to Configure.pl should produce .c files from the .pmc source files without #line directives. This is necessary for debugging, among other things. However when I try to debug in master with that option, I still have .c files filled with #line directives.

When I did a normal (option-less) configuration, and then grepped for ^#line, I got these counts:

./src/pmc/null.c:15
./src/pmc/fixedintegerarray.c:70
./src/pmc/callcontext.c:104
./src/pmc/default.c:205
./src/pmc/env.c:33
...
./src/pmc/undef.c:31

When I configured with --no-line-directives, I got these counts:

./src/pmc/null.c:0
./src/pmc/fixedintegerarray.c:0
./src/pmc/callcontext.c:0
./src/pmc/default.c:0
./src/pmc/env.c:0
./src/pmc/key.c:0
...
./src/pmc/undef.c:0

So either I'm not understanding your problem or I can't reproduce it.

kid51

  Changed 11 years ago by bacek

  • status changed from new to closed
  • resolution set to worksforme

Hello.

Resolving ticket as invalid. No one can reproduce it.

Whiteknight, you probably have to make reconfig after changing Configure.pl flags.

-- Bacek

Note: See TracTickets for help on using tickets.