Ticket #2028 (new deprecation)

Opened 3 years ago

Last modified 3 years ago

pcre is deprecated

Reported by: NotFound Owned by:
Priority: normal Milestone:
Component: configure Version: 3.1.0
Severity: medium Keywords:
Cc: smash, fperrad Language:
Patch status: Platform:

Description

The pcre module is deprecated from core. It will be moved to another repo if someone wants to take care of it, or just removed if not.

This is an early notice, waiting a few days before adding to api.yaml just in case someone has a good reason to keep it.

Attachments

pcre.files.with.txt Download (1.0 KB) - added by jkeenan 3 years ago.
Source code files containing string =~ m/pcre/i

Change History

Changed 3 years ago by jkeenan

Source code files containing string =~ m/pcre/i

Changed 3 years ago by jkeenan

  • cc smash, fperrad added

Have attached file with list of source code files containing pcre|PCRE. We should probably look into the following subset of that list to see why people wanted PCRE in Parrot in the first place:

./docs/book/draft/appd_build_options.pod
./docs/book/draft/chXX_library.pod
./examples/library/ncurses_life.pir
./examples/library/pcre.pir
./runtime/parrot/library/libpcre.pir
./runtime/parrot/library/pcre.pir
./src/nci/extra_thunks.nci
./t/examples/library.t
./t/library/pcre.t
./tools/dev/mk_inno.pl

Changed 3 years ago by jkeenan

cc-ing the two developers who contributed the most to the auto::pcre config step, to get their input.

Changed 3 years ago by jkeenan

  • component changed from none to configure
Note: See TracTickets for help on using tickets.