Ticket #2030 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

t/pmc/structview.t fails with memory PANIC

Reported by: doughera Owned by: plobsing
Priority: normal Milestone:
Component: none Version: 3.1.0
Severity: medium Keywords:
Cc: gerd Language:
Patch status: Platform: linux

Description

As of RELEASE_3_1_0-329-geb0ebb2 the t/pmc/structview.t test fails on Linux/386 with:

1..16
ok 1 - 8 bits in one byte
ok 2 - single byte is byte-aligned
ok 3 - byte-aligned single byte is single byte when aligned
ok 4 - allocate an instance
ok 5 - bitpattern gives correct byte
ok 6 - unaligned struct first byte
ok 7 - unaligned struct second byte
Failed allocation of 3219616584 bytes
Parrot VM: PANIC: Out of mem!
C file src/gc/alloc_memory.c, line 87
Parrot file (not available), line (not available)

We highly suggest you notify the Parrot team if you have not been working on
Parrot.  Use parrotbug (located in parrot's root directory) or send an
e-mail to parrot-dev@lists.parrot.org.
Include the entire text of this error message and the text of the script that
generated the error.  If you've made any modifications to Parrot, please
describe them as well.

Version     : 3.1.0-devel
Configured  : Sat Feb 26 19:51:13 2011 GMT
Architecture: i386-linux
Interp Flags: (no interpreter)
Exceptions  : (missing from core)

Dumping Core...
Sorry, coredump is not yet implemented for this platform.

This was compiled with gcc-4.3.2 with no optimization, but changing the optimization level (or even the compiler) didn't make any significant difference.

Change History

  Changed 3 years ago by jkeenan

See also TT #2029.

follow-up: ↓ 4   Changed 3 years ago by jkeenan

On linux/i386 at commit 3ccd945640, I got same failure as in description.

  Changed 3 years ago by gerd

  • cc gerd added

in reply to: ↑ 2   Changed 3 years ago by plobsing

Replying to jkeenan:

On linux/i386 at commit 3ccd945640, I got same failure as in description.

I was unable to reproduce this on i686/linux/gcc-4.5, but have just recently been able to try i686/linux/gcc-4.4 where the problem does manifest.

in reply to: ↑ description   Changed 3 years ago by plobsing

  • owner set to plobsing

Replying to doughera:

As of RELEASE_3_1_0-329-geb0ebb2 the t/pmc/structview.t test fails on Linux/386 with: {{{ 1..16 ok 1 - 8 bits in one byte ok 2 - single byte is byte-aligned ok 3 - byte-aligned single byte is single byte when aligned ok 4 - allocate an instance ok 5 - bitpattern gives correct byte ok 6 - unaligned struct first byte ok 7 - unaligned struct second byte Failed allocation of 3219616584 bytes Parrot VM: PANIC: Out of mem! C file src/gc/alloc_memory.c, line 87 Parrot file (not available), line (not available) We highly suggest you notify the Parrot team if you have not been working on Parrot. Use parrotbug (located in parrot's root directory) or send an e-mail to parrot-dev@…. Include the entire text of this error message and the text of the script that generated the error. If you've made any modifications to Parrot, please describe them as well. Version : 3.1.0-devel Configured : Sat Feb 26 19:51:13 2011 GMT Architecture: i386-linux Interp Flags: (no interpreter) Exceptions : (missing from core) Dumping Core... Sorry, coredump is not yet implemented for this platform. }}} This was compiled with gcc-4.3.2 with no optimization, but changing the optimization level (or even the compiler) didn't make any significant difference.

This should be resolved in 298b2e2.

  Changed 3 years ago by jkeenan

Works for me on linux/i386 at 4629233bb1. Thank you very much.

kid51

  Changed 3 years ago by plobsing

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.