Ticket #2041 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

:immediate ignored when compiling to PBC

Reported by: jonathan Owned by:
Priority: normal Milestone:
Component: imcc Version: 3.1.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

:immediate is ignored when compiling to PBC:

C:\Consulting\nqp>type bug.pir
.sub '' :immediate
    say "in immediate"
.end

.sub '' :main
    say "run"
.end

C:\Consulting\nqp>parrot_install\bin\parrot.exe bug.pir
in immediate
run

C:\Consulting\nqp>parrot_install\bin\parrot.exe -o bug.pbc bug.pir

C:\Consulting\nqp>

Change History

Changed 3 years ago by pmichaud

FWIW, I think this is likely a duplicate of TT #1374.

Pm

Changed 3 years ago by plobsing

  • status changed from new to closed
  • resolution set to fixed

Not anymore. Due to recent work in IMCC, compilation of bug.pir to bug.pbc now emits "in immediate", as would be expected.

Note: See TracTickets for help on using tickets.