Ticket #2104 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

recent parrot changes broke rakudo

Reported by: moritz Owned by: jkeenan
Priority: normal Milestone:
Component: language Version: 3.2.0
Severity: medium Keywords:
Cc: petdance Language:
Patch status: Platform:

Description

Recent parrot versions like for example RELEASE_3_3_0-60-g97c32c7 break several spectest files in rakudo, for example t/spec/S02-builtin_data_types/subscripts_and_context.t. The 3.3.0 release was fine.

An initial bisect identified this commit as the offensive one, but I'm not sure how reliable it is:

c1f77f7eb90041468c3b13f5b48ae2ca1d1c37a5 is the first bad commit
commit c1f77f7eb90041468c3b13f5b48ae2ca1d1c37a5
Author: Andy Lester <andy@petdance.com>
Date:   Tue Apr 26 23:01:17 2011 -0500

    now that PMCNULL is not NULL, we can update function annotations

:040000 040000 ebb5e4bd76f84e5e185f954de57d9345dfbc4ac5 304e309e2a675e1f3b523d5131a26d8c5911c061 M      include
:040000 040000 e839b4856be23bb47f4cfbaba51c4b501e1a7ffb 07c05cd195811b7890269e6ec7b704d804eb5ecd M      src

Change History

Changed 3 years ago by moritz

I've confirmed that this is indeed the offending commit - reverting it on top of RELEASE_3_3_0-64-ga67bfbf makes rakudo pass the test files in question.

Changed 3 years ago by moritz

I've now reverted the offending commit in master, it's not reverted in the pmcnull_annotations branch.

The problem is that rakudo uses some static variables at C level that are STRINGs, and the compiler complains about initializing them with STRINGNULL, because it's not constant.

So a more sophisticated solution must be found, for which I don't feel qualified.

Changed 3 years ago by jkeenan

  • status changed from new to assigned
  • cc petdance added
  • owner set to jkeenan

Moritz, unless the Rakudo spec tests you mentioned are continuing to break when built on Parrot's master, I'm inclined to think that we can close this ticket.

I'm going to cc petdance so he can comment. Perhaps the revisions he attempted can be made in the future provided they get tested all the way through Rakudo. If I hear nothing in three days, then I will close the ticket.

Thank you very much.

kid51

Changed 3 years ago by jkeenan

  • status changed from assigned to closed
  • resolution set to fixed

No complaints received in the specified timeframe. Closing ticket.

Note: See TracTickets for help on using tickets.