Ticket #2107 (new bug)

Opened 3 years ago

Last modified 3 years ago

"Failed to load libpcre" during build

Reported by: colomon Owned by:
Priority: critical Milestone:
Component: configure Version: 3.4.0
Severity: high Keywords:
Cc: Language: perl6
Patch status: Platform:

Description


Attachments

pcre-bug Download (2.7 KB) - added by colomon 3 years ago.

Change History

Changed 3 years ago by colomon

  Changed 3 years ago by tadzik

I have the same problem (linux, amd64), worked around it using --without-pcre as a build parameter.

  Changed 3 years ago by colomon

I should have said that I worked around it the same way.

  Changed 3 years ago by jkeenan

Could I ask that this ticket be evaluated in consideration with these currently open tickets that appear to touch on PCRE?

TT #2028

TT #2024

TT #1795

Thank you very much.

kid51

  Changed 3 years ago by jkeenan

  • component changed from none to configure

  Changed 3 years ago by pmichaud

  • priority changed from normal to critical
  • version changed from 3.3.0 to 3.4.0
  • severity changed from medium to high

  Changed 3 years ago by pmichaud

  • lang set to perl6

  Changed 3 years ago by jkeenan

Additional PCRE-related build failure reported today:

 Configure.pl output

 make output

  Changed 3 years ago by moritz

MvG++ posted a patch at  https://github.com/parrot/parrot/pull/144 -- somebody please review and apply it.

follow-up: ↓ 10   Changed 3 years ago by jimmy

merged in 2d6e52a64f865819d73ed59e37496c0b20d39457, test welcome

in reply to: ↑ 9   Changed 3 years ago by jkeenan

Replying to jimmy:

merged in 2d6e52a64f865819d73ed59e37496c0b20d39457, test welcome

Would it be possible for you to write such a test?

Thank you very much.

kid51

Note: See TracTickets for help on using tickets.