Ticket #2115 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

t/tools/dump_pbc.t and pbc_disassemble.t: new test failures

Reported by: jkeenan Owned by: dukeleto
Priority: normal Milestone:
Component: tools Version: 3.4.0
Severity: medium Keywords:
Cc: petdance Language:
Patch status: Platform: all

Description

The following test failures, which I have observed on both linux/i386 and darwin/ppc, emerged somewhere in the last 24 hours.

src/debug.c:2899: failed assertion 'command_unused'
Backtrace - Obtained 8 stack frames (max trace depth is 32).
/home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d5a66a]
/home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_confess+0x9a) [0xb7d5a81a]
/home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d4c59e]
/home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_disassemble+0x116) [0xb7d51336]
/home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_api_disassemble_bytecode+0x16c) [0xb7d54f9c]
/home/jimk/gitwork/parrot/pbc_disassemble [0x8048ead]
/lib/libc.so.6(__libc_start_main+0xe5) [0xb6fc7455]
/home/jimk/gitwork/parrot/pbc_disassemble [0x8048a61]
Attempting to get PIR backtrace.  No guarantees.  Here goes...
current instr.: 'main' pc 0 (examples/tutorial/01_temp_var.pir:19)
No disassembly; errors: 6,  at tools/dev/dump_pbc.pl line 65.

#   Failed test '01_temp_var.pir'
#   at t/tools/dump_pbc.t line 39.
#                   ''
#     doesn't match '(?-xism:\=head1\ Simple\ Variables)'
# Looks like you failed 1 test of 1.
t/tools/dump_pbc.t ......... 
1..1
not ok 1 - 01_temp_var.pir
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 
sh: line 1: 20315 Aborted                 
  ./pbc_disassemble t/tools/pbc_disassemble.t.5.pbc > t/tools/pbc_disassemble.t.5.stdout 2>&1

#   Failed test 'pbc_disassemble numeric ops'
#   at t/tools/pbc_disassemble.t line 129.
#                   'src/debug.c:2899: failed assertion 'command_unused'
# Backtrace - Obtained 8 stack frames (max trace depth is 32).
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7dce66a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_confess+0x9a) [0xb7dce81a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7dc059e]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_disassemble+0x116) [0xb7dc5336]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_api_disassemble_bytecode+0x16c) [0xb7dc8f9c]
# ./pbc_disassemble [0x8048ead]
# /lib/libc.so.6(__libc_start_main+0xe5) [0xb703b455]
# ./pbc_disassemble [0x8048a61]
# Attempting to get PIR backtrace.  No guarantees.  Here goes...
# current instr.: 'main' pc 0 (t/tools/pbc_disassemble.t.5.pir:2)
# '
#     doesn't match '(?ms-xi:PMC_CONST.*set_n_nc.*print_n)'
sh: line 1: 20318 Aborted                 
  ./pbc_disassemble t/tools/pbc_disassemble.t.6.pbc > t/tools/pbc_disassemble.t.6.stdout 2>&1

#   Failed test 'pbc_disassemble integer ops'
#   at t/tools/pbc_disassemble.t line 129.
#                   'src/debug.c:2899: failed assertion 'command_unused'
# Backtrace - Obtained 8 stack frames (max trace depth is 32).
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d7866a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_confess+0x9a) [0xb7d7881a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d6a59e]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_disassemble+0x116) [0xb7d6f336]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_api_disassemble_bytecode+0x16c) [0xb7d72f9c]
# ./pbc_disassemble [0x8048ead]
# /lib/libc.so.6(__libc_start_main+0xe5) [0xb6fe5455]
# ./pbc_disassemble [0x8048a61]
# Attempting to get PIR backtrace.  No guarantees.  Here goes...
# current instr.: 'main' pc 0 (t/tools/pbc_disassemble.t.6.pir:2)
# '
#     doesn't match '(?ms-xi:PMC_CONST.*set_i_ic.*print_i)'
sh: line 1: 20321 Aborted                 
  ./pbc_disassemble t/tools/pbc_disassemble.t.7.pbc > t/tools/pbc_disassemble.t.7.stdout 2>&1

#   Failed test 'pbc_disassemble pmc ops'
#   at t/tools/pbc_disassemble.t line 129.
#                   'src/debug.c:2899: failed assertion 'command_unused'
# Backtrace - Obtained 8 stack frames (max trace depth is 32).
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d7b66a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_confess+0x9a) [0xb7d7b81a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d6d59e]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_disassemble+0x116) [0xb7d72336]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_api_disassemble_bytecode+0x16c) [0xb7d75f9c]
# ./pbc_disassemble [0x8048ead]
# /lib/libc.so.6(__libc_start_main+0xe5) [0xb6fe8455]
# ./pbc_disassemble [0x8048a61]
# Attempting to get PIR backtrace.  No guarantees.  Here goes...
# current instr.: 'main' pc 0 (t/tools/pbc_disassemble.t.7.pir:2)
# '
#     doesn't match '(?ms-xi:PMC_CONST.*new_p_sc.*"ResizablePMCArray".*set_p_kic_ic\s*P.*set_i_p_kic\s*I.*)'
sh: line 1: 20324 Aborted                 
  ./pbc_disassemble t/tools/pbc_disassemble.t.8.pbc > t/tools/pbc_disassemble.t.8.stdout 2>&1

#   Failed test 'pbc_disassemble string ops'
#   at t/tools/pbc_disassemble.t line 129.
#                   'src/debug.c:2899: failed assertion 'command_unused'
# Backtrace - Obtained 8 stack frames (max trace depth is 32).
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7db966a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_confess+0x9a) [0xb7db981a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7dab59e]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_disassemble+0x116) [0xb7db0336]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_api_disassemble_bytecode+0x16c) [0xb7db3f9c]
# ./pbc_disassemble [0x8048ead]
# /lib/libc.so.6(__libc_start_main+0xe5) [0xb7026455]
# ./pbc_disassemble [0x8048a61]
# Attempting to get PIR backtrace.  No guarantees.  Here goes...
# current instr.: 'main' pc 0 (t/tools/pbc_disassemble.t.8.pir:2)
# '
#     doesn't match '(?ms-xi:PMC_CONST.*set_s_sc\s*S.*print_s\s*S.*print_sc)'
sh: line 1: 20327 Aborted                 
  ./pbc_disassemble t/tools/pbc_disassemble.t.9.pbc > t/tools/pbc_disassemble.t.9.stdout 2>&1

#   Failed test 'pbc_disassemble utf8 string'
#   at t/tools/pbc_disassemble.t line 129.
#                   'src/debug.c:2899: failed assertion 'command_unused'
# Backtrace - Obtained 8 stack frames (max trace depth is 32).
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d8f66a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_confess+0x9a) [0xb7d8f81a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d8159e]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_disassemble+0x116) [0xb7d86336]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_api_disassemble_bytecode+0x16c) [0xb7d89f9c]
# ./pbc_disassemble [0x8048ead]
# /lib/libc.so.6(__libc_start_main+0xe5) [0xb6ffc455]
# ./pbc_disassemble [0x8048a61]
# Attempting to get PIR backtrace.  No guarantees.  Here goes...
# current instr.: 'main' pc 0 (t/tools/pbc_disassemble.t.9.pir:2)
# '
#     doesn't match '(?ms-xi:set_s_sc S0,utf8:"Hello")'
sh: line 1: 20330 Aborted                 
  ./pbc_disassemble t/tools/pbc_disassemble.t.10.pbc > t/tools/pbc_disassemble.t.10.stdout 2>&1

#   Failed test 'pbc_disassemble utf16 string'
#   at t/tools/pbc_disassemble.t line 129.
#                   'src/debug.c:2899: failed assertion 'command_unused'
# Backtrace - Obtained 8 stack frames (max trace depth is 32).
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d6966a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_confess+0x9a) [0xb7d6981a]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0 [0xb7d5b59e]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_disassemble+0x116) [0xb7d60336]
# /home/jimk/gitwork/parrot/blib/lib/libparrot.so.3.4.0(Parrot_api_disassemble_bytecode+0x16c) [0xb7d63f9c]
# ./pbc_disassemble [0x8048ead]
# /lib/libc.so.6(__libc_start_main+0xe5) [0xb6fd6455]
# ./pbc_disassemble [0x8048a61]
# Attempting to get PIR backtrace.  No guarantees.  Here goes...
# current instr.: 'main' pc 0 (t/tools/pbc_disassemble.t.10.pir:2)
# '
#     doesn't match '(?ms-xi:set_s_sc S0,utf16:"H\\0e\\0l\\0l\\0o\\0")'
# Looks like you failed 6 tests of 10.
t/tools/pbc_disassemble.t .. 
1..10
ok 1 - pbc_disassemble help message
ok 2 - pbc_disassemble bad option
ok 3 - pbc_disassemble every option
ok 4 - pbc_disassemble bad bytecode file
not ok 5 - pbc_disassemble numeric ops
not ok 6 - pbc_disassemble integer ops
not ok 7 - pbc_disassemble pmc ops
not ok 8 - pbc_disassemble string ops
not ok 9 - pbc_disassemble utf8 string
not ok 10 - pbc_disassemble utf16 string
Dubious, test returned 6 (wstat 1536, 0x600)
Failed 6/10 subtests 

Test Summary Report
-------------------
t/tools/dump_pbc.t       (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
t/tools/pbc_disassemble.t (Wstat: 1536 Tests: 10 Failed: 6)
  Failed tests:  5-10
  Non-zero exit status: 6
Files=2, Tests=11,  1 wallclock secs 
  ( 0.02 usr  0.01 sys +  0.34 cusr  0.13 csys =  0.50 CPU)
Result: FAIL

Change History

  Changed 3 years ago by jkeenan

  • owner set to dukeleto
  • platform set to all
  • component changed from none to tools

  Changed 3 years ago by jkeenan

  • owner changed from dukeleto to petdance

From taptinder, it appears that make began failing on linux at 0004e42d and was fixed in 6d1a1fcf. However, at 6d1a1fcf, the two test failures I reported above began. So it appears that make was run but make test was not.

  Changed 3 years ago by jkeenan

  • cc petdance added
  • owner changed from petdance to dukeleto

follow-up: ↓ 5   Changed 3 years ago by cotto

NotFound seems to have fixed this in 610bb7a59ba. A ppc VM that was previously exhibiting to the bug stopped with that commit. I'll let jkeenan verify that it's also fixed for him, but it'd be surprising if it weren't.

in reply to: ↑ 4 ; follow-up: ↓ 6   Changed 3 years ago by jkeenan

Replying to cotto:

I'll let jkeenan verify that it's also fixed for him, but it'd be surprising if it weren't.

I've been able to verify that the fix works on linux/i386, but have not yet had time to try it on darwin/ppc. I hope to do that by the weekend.

Thank you very much.

kid51

in reply to: ↑ 5   Changed 3 years ago by jkeenan

  • status changed from new to closed
  • resolution set to fixed

Replying to jkeenan:

I've been able to verify that the fix works on linux/i386, but have not yet had time to try it on darwin/ppc. I hope to do that by the weekend.

Confirmed PASS on darwin/ppc. Thanks to all. Closing ticket.

kid51

Note: See TracTickets for help on using tickets.