Ticket #2147 (new bug)

Opened 11 years ago

Last modified 10 years ago

ops2c and a variable with "return" in its name

Reported by: jonathan Owned by: dukeleto
Priority: minor Milestone:
Component: tools Version: 3.5.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform: all


15:00 <@jnthn__> So it turns out that if you have a variable called returns or
                 return_type in an ops file, ops2c goes and wraps it up in an
                 extra level of parens, causing an innevitable C syntax error.
15:01 <@jnthn__> foo->return_type ends up coming out as foo->(return_type)
15:01 <@jnthn__> Rename that to rtype and it works
15:01 <@jnthn__> :/

Change History

Changed 10 years ago by dukeleto

Did this ever get fixed?

Note: See TracTickets for help on using tickets.