Ticket #2179 (closed bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Bug in setup-parrot-3.6.0.exe broke PATH

Reported by: "mzoppet@…> Owned by: fperrad
Priority: normal Milestone: 3.7
Component: install Version: 3.6.0
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

Dear team,

I downloaded for my first time a Parrot setup for Windows, and tested it on my Windows 7 environment.
After the installation I had a lot of problems because I lost the capacity to run quite every command.

I discovered that the installer changed the type of the PATH environment variable stored in the registry. Since NT 3.1 this key value must be of type "REG_EXPAND_SZ".

I retrieved the source and the broken file should be "\tools\dev\mk_inno.pl" at line 89, where it is used:

   ValueType: string;

instead of 

   ValueType: expandsz;

This setting is OS version dependent. If your target is to support only Windows versions officially supported by Microsoft (currently XP SP3 or newer) simply change the ValueType to "expandsz". Otherwise you must do some deep checks on the OS version in use at installation time.

Best regards,
Mario Zoppetti

http://support.microsoft.com/kb/102985

http://www.jrsoftware.org/ishelp/index.php?topic=registrysection

How do I modify the PATH environment variable when running an Inno Setup Installer?
http://stackoverflow.com/questions/3304463/how-do-i-modify-the-path-environment-variable-when-running-an-inno-setup-installe

 

untitled-part.html Download

Attachments

untitled-part.html Download (1.4 KB) - added by mzoppet@… 3 years ago.
Added by email2trac

Change History

Changed 3 years ago by mzoppet@…

Changed 3 years ago by mzoppet@…

This message has 1 attachment(s)

Changed 3 years ago by mzoppet@…

Added by email2trac

Changed 3 years ago by jkeenan

  • component changed from none to install
  • type set to bug

Changed 3 years ago by fperrad

  • owner set to fperrad
  • milestone changed from 2.11 to 3.7

setup-parrot-3.7.0.exe was shipped with this fix.

could you test it ?

Changed 3 years ago by jkeenan

  • status changed from new to closed
  • resolution set to fixed

The original poster sent an email to parrot-tickets, which would have required moderator approval and which would not, in any event, have made it into Trac. So I am posting the content of the email here in Trac. And since it appears the problem is resolved, I'm closing the ticket as well. -- kid51

Dear team,

I confirm that for my PC using setup-parrot-3.7.0 the problem is fixed.

Many thanks for the VERY quick fix!

Best regards, Mario Zoppetti

Note: See TracTickets for help on using tickets.