Ticket #284 (closed todo: fixed)

Opened 6 years ago

Last modified 6 years ago

rename 'pdump' to 'pbc_dump'

Reported by: coke Owned by: jkeenan
Priority: normal Milestone:
Component: none Version:
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

This will provide consistency and avoid potential name conflict with:

 http://samy.pl/pdump/

Attachments

rename-pdump.patch Download (23.5 KB) - added by fperrad 6 years ago.

Change History

Changed 6 years ago by fperrad

follow-up: ↓ 2   Changed 6 years ago by fperrad

This patch does the job.

in reply to: ↑ 1 ; follow-up: ↓ 3   Changed 6 years ago by jkeenan

Replying to fperrad:

This patch does the job.

François,

I tried to apply this patch in order to test it, but I could not apply the patch cleanly. I got output from patch -p0 like this:

can't find file to patch at input line 274
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: src/pbc_dump.c
|===================================================================
|--- src/pbc_dump.c     (revision 36414)
|+++ src/pbc_dump.c     (working copy)
--------------------------
File to patch: 

I suspect that the problem is that while src/pdump.c is completely deleted in the patch, its replacement, src/pbc_dump.c, only appears as a diff.

Index: src/pbc_dump.c
===================================================================
--- src/pbc_dump.c  (revision 36414)
+++ src/pbc_dump.c  (working copy)
@@ -4,13 +4,13 @@

 =head1 NAME

-pdump - Dump or convert Parrot bytecode (PBC) files
+pbc_dump - Dump or convert Parrot bytecode (PBC) files

 =head1 SYNOPSIS

- pdump [-tdh] [--terse|--disassemble|--header-only] file.pbc
+ pbc_dump [-tdh] [--terse|--disassemble|--header-only] file.pbc

- pdump -o converted.pbc file.pbc
+ pbc_dump -o converted.pbc file.pbc
...

Other than this, the patch looks very thorough. Could you try re-pulling it?

Thank you very much.
kid51

in reply to: ↑ 2   Changed 6 years ago by jkeenan

Replying to jkeenan:

Am reworking the patch. I now think this is not a problem with François' patch but with patch itself.

  Changed 6 years ago by jkeenan

  • owner set to jkeenan
  • status changed from new to assigned

  Changed 6 years ago by jkeenan

Patch applied in r36419.

(I think the problem I experienced earlier is a limitation in the use of svn diff to create a patch. I did an svn cp src/pdump.c src/pbc_dump.c, then edited pbc_dump.c to match François' revisions, then did svn rm src/pdump.c. When I then did an svn diff myself, I got exactly the same patch that François submitted, i.e., a diff on pbc_dump.c but not the whole of that newly created file.)

  Changed 6 years ago by jkeenan

  • status changed from assigned to closed
  • resolution set to fixed

No complaints received; closing ticket.

  Changed 6 years ago by Util

In r36805, the svn:ignore property is updated to match the other changes in this ticket. Before this, svn status was flagging pbc_dump as '?'.

Note: See TracTickets for help on using tickets.