Ticket #294 (closed patch: fixed)

Opened 5 years ago

Last modified 5 years ago

[PATCH] Pick correct format for Configure.pl --floatval='long double'

Reported by: doughera Owned by:
Priority: normal Milestone:
Component: configure Version:
Severity: medium Keywords:
Cc: Language:
Patch status: applied Platform:

Description

The attached patch picks the correct format for the case where Configure.pl was called with --floatval='long double'. It should usually be %.15Lg, but Perl 5's Configure also checks for a variety of other possibilities, so just use that result.

Attachments

ld-format.patch Download (1.0 KB) - added by doughera 5 years ago.

Change History

Changed 5 years ago by doughera

follow-up: ↓ 2   Changed 5 years ago by Infinoid

  • status changed from new to closed
  • resolution set to fixed
  • patch set to applied

Thanks, applied in r36495.

in reply to: ↑ 1   Changed 5 years ago by Infinoid

Replying to Andy D's email:

Thanks for applying that. I have one additional fix-up right away. It turns out that this will cause a failure in one of the post-configure tests. The problem is that the test is hard-coded to look for the wrong answer. I propose just deleting the test. (Alternatively, one could copy and paste the code to look for the correct answer from the config step, but I don't know what that would actually end up testing, other than one's ability to copy and paste correctly.)

Yep, some folks in the IRC channel noticed that (mikehh++) and so I checked in a fixed test in r36502. The test now verifies that I do have the ability to copy and paste correctly. :) (I'll remove that test if I remember to, hopefully I won't forget.)

[I've replied to the parrot-tickets list, but I don't know if that actually works. (I guess I'll find out.)]

Nope, that doesn't quite work yet. It's being worked on; ticket #49 tracks that.

Note: See TracTickets for help on using tickets.