Ticket #319 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

[BUG] t/compilers/pct/complete_workflow.t, t/compilers/pct/pct_hllcompiler.t, t/library/tcl_glob.t, t/library/test_more.t: New test failures

Reported by: jkeenan Owned by: pmichaud
Priority: normal Milestone: 0.9.1
Component: PCT Version:
Severity: medium Keywords: PCT library
Cc: Language:
Patch status: Platform:

Description

Test Summary Report
-------------------
t/compilers/pct/complete_workflow       (Wstat: 1536 Tests: 54 Failed: 6)
  Failed tests:  9, 18, 27, 36, 45, 54
  Non-zero exit status: 6
t/compilers/pct/pct_hllcompiler         (Wstat: 256 Tests: 5 Failed: 1)
  Failed test:  2
  Non-zero exit status: 1
t/library/tcl_glob                      (Wstat: 11 Tests: 0 Failed: 0)
  Parse errors: Bad plan.  You planned 24 tests but ran 0.
t/library/test_more                     (Wstat: 11 Tests: 46 Failed: 0)
  Parse errors: Bad plan.  You planned 74 tests but ran 46.
Files=390, Tests=11737, 638 wallclock secs ( 1.72 usr  0.38 sys + 105.92 cusr 24.66 csys = 132.68 CPU)
Result: FAIL

Here's the SVN revision info:

$ svn info
Path: .
URL: https://svn.parrot.org/parrot/trunk
Repository Root: https://svn.parrot.org/parrot
Repository UUID: d31e2699-5ff4-0310-a27c-f18f2fbe73fe
Revision: 36597
Node Kind: directory
Schedule: normal
Last Changed Author: allison
Last Changed Rev: 36595
Last Changed Date: 2009-02-11 15:42:56 -0500 (Wed, 11 Feb 2009)

Change History

follow-up: ↓ 2   Changed 5 years ago by Infinoid

I saw some of these failures earlier today but am unable to reproduce it with current versions of trunk. I think it was fixed in r36598 or somewhere near there. Can you still reproduce it after a svn update?

Thanks,

Mark

in reply to: ↑ 1   Changed 5 years ago by jkeenan

  • status changed from new to closed
  • resolution set to fixed

Replying to Infinoid:

I saw some of these failures earlier today but am unable to reproduce it with current versions of trunk. I think it was fixed in r36598 or somewhere near there. Can you still reproduce it after a svn update?

All tests passing as observed at r36632. See  my Smolder report.

Thanks for looking into this. Closing ticket.

kid51

Note: See TracTickets for help on using tickets.