Ticket #368 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

t/dynpmc/*.t: many test failures

Reported by: jkeenan Owned by: jkeenan
Priority: normal Milestone:
Component: core Version: trunk
Severity: high Keywords: dynpmc
Cc: Language:
Patch status: Platform:

Description

The following failures were observed on Linux at both r36949 and r36950.

Test Summary Report
-------------------
t/dynpmc/gdbmhash                       (Wstat: 2816 Tests: 13 Failed: 11)
  Failed tests:  3-13
  Non-zero exit status: 11
t/dynpmc/md2                            (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
t/dynpmc/md4                            (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
t/dynpmc/md5                            (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
t/dynpmc/ripemd160                      (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
t/dynpmc/sha                            (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
t/dynpmc/sha1                           (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
t/dynpmc/sha256                         (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
t/dynpmc/sha512                         (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
Files=396, Tests=11701, 424 wallclock secs ( 1.69 usr  0.30 sys + 104.41 cusr 16.63 csys = 123.03 CPU)
Result: FAIL

See, for example,  this Smolder report on an ordinary Linux box.

Thank you very much.
kid51

Attachments

t.dynpmc.t.some.failures.txt Download (5.9 KB) - added by jkeenan 5 years ago.
Output of 'prove -v' on 3 of the t/dynpmc/*.t files that are failing
make.dynpmc.output.txt Download (35.9 KB) - added by jkeenan 5 years ago.
Output of make -C src/dynpmc and -C src/dynoplibs, as requested by fperrad, at r36965

Change History

Changed 5 years ago by jkeenan

Output of 'prove -v' on 3 of the t/dynpmc/*.t files that are failing

follow-ups: ↓ 2 ↓ 4   Changed 5 years ago by fperrad

Add missing libraries (crypto & gdbm) in r36956.

Need test on any platform.

in reply to: ↑ 1 ; follow-ups: ↓ 3 ↓ 5   Changed 5 years ago by jkeenan

Replying to fperrad:

Add missing libraries (crypto & gdbm) in r36956.

Unfortunately, this appears not to have improved things. I'm still getting the same failures as of r36965. See  my latest Smolder report on Linux.

Thank you very much.
kid51

in reply to: ↑ 2   Changed 5 years ago by fperrad

Replying to jkeenan:

Replying to fperrad:

Add missing libraries (crypto & gdbm) in r36956.

Unfortunately, this appears not to have improved things. I'm still getting the same failures as of r36965. See  my latest Smolder report on Linux.

It's a build problem. Test report is useless. Send me the output of : make -C src/dynpmc

Thank you very much.
kid51

in reply to: ↑ 1   Changed 5 years ago by fperrad

Replying to fperrad:

Add missing libraries (crypto & gdbm) in r36956. Need test on any platform.

fix on Linux with r36959.

in reply to: ↑ 2 ; follow-up: ↓ 6   Changed 5 years ago by fperrad

Replying to jkeenan:

Unfortunately, this appears not to have improved things. I'm still getting the same failures as of r36965. See  my latest Smolder report on Linux.

Seems fixed by r36972.

Thank you very much.
kid51

Changed 5 years ago by jkeenan

Output of make -C src/dynpmc and -C src/dynoplibs, as requested by fperrad, at r36965

in reply to: ↑ 5   Changed 5 years ago by jkeenan

  • status changed from new to assigned
  • owner set to jkeenan

Replying to fperrad:

Seems fixed by r36972.

Confirmed, as demonstrated by  this Smolder report.

François, thanks for investigating this. Although the problem is solved, for your reference I am attaching the make output you requested. Note lines 22-28.

kid51

  Changed 5 years ago by jkeenan

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.