Ticket #390 (closed bug: fixed)

Opened 6 years ago

Last modified 5 years ago

make testj: multiple test failures

Reported by: jkeenan Owned by: jkeenan
Priority: major Milestone:
Component: core Version: trunk
Severity: high Keywords:
Cc: rurban fperrad Language:
Patch status: Platform:

Description

As originally reported on list by rurban:

jit is failing now. mingw make testj is now failing with these errors.

t/op/trans.t                         (Wstat: 256 Tests: 22 Failed: 1)
  Failed test:  11
  TODO passed:   13
  Non-zero exit status: 1
t/pmc/fixedintegerarray.t            (Wstat: 256 Tests: 11 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/library/md5.t                      (Wstat: 1536 Tests: 6 Failed: 6)
  Failed tests:  1-6
  Non-zero exit status: 6
t/library/mt19937ar.t                (Wstat: 256 Tests: 10 Failed: 1)
  Failed test:  10
  Non-zero exit status: 1
t/library/rand.t                     (Wstat: 256 Tests: 2 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1

I guess rand, the mersenne twister and md5 are caused by the recent rand and md5 changes. maybe another jit rounding issue that was uncovered now.

repro:

set TEST_PROG_ARGS=-j
prove t\library\md5.t t/library/rand.t t/library/mt19937ar.t

confirmed on fedora core 1

I observed most of the same errors on Linux at r37067.

t/pmc/fixedintegerarray            (Wstat: 256 Tests: 11 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/pmc/packfileconstanttable        (Wstat: 256 Tests: 3 Failed: 1)
  Failed test:  3
  Non-zero exit status: 1
t/library/md5                      (Wstat: 1536 Tests: 6 Failed: 6)
  Failed tests:  1-6
  Non-zero exit status: 6
t/library/mt19937ar                (Wstat: 256 Tests: 10 Failed: 1)
  Failed test:  10
  Non-zero exit status: 1
t/library/rand                     (Wstat: 256 Tests: 2 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1 

Based on the fact that these cropped up around the same time as the failure in t/pmc/packfileconstanttable.t, my hunch is that r37044 and r37045 need to be examined.

Thank you very much.

Change History

  Changed 5 years ago by jkeenan

My hunch yesterday was incorrect. I now believe that these failures occurred prior to r37044, as I have observed them in r37039 and r37043 as well.

  Changed 5 years ago by coke

Ran an svn-bisect, focusing just on t/pmc/fixedintegerarray.t.

With JIT, that test last worked on r36062. there were a few versions that didn't build, and then r36056 failed.

follow-up: ↓ 4   Changed 5 years ago by mikehh

As of r37197 I get the following Test Summary for the jit core on Kubuntu Intrepid i386:

Test Summary Report
-------------------
t/compilers/imcc/syn/hll.t           (Wstat: 0 Tests: 2 Failed: 0)
  TODO passed:   2
t/op/exceptions.t                    (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   23
t/pmc/exception.t                    (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   26
t/pmc/fixedintegerarray.t            (Wstat: 256 Tests: 11 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/library/md5.t                      (Wstat: 1536 Tests: 6 Failed: 6)
  Failed tests:  1-6
  Non-zero exit status: 6
t/library/mt19937ar.t                (Wstat: 256 Tests: 10 Failed: 1)
  Failed test:  10
  Non-zero exit status: 1
Files=252, Tests=8118, 280 wallclock secs ( 2.84 usr  0.65 sys + 75.51 cusr 33.53 csys = 112.53 CPU)
Result: FAIL

Cheers,

Michael

in reply to: ↑ 3   Changed 5 years ago by jkeenan

Replying to mikehh:

As of r37197 I get the following Test Summary for the jit core on Kubuntu Intrepid i386:

As of r37205, I am getting the same results on Linux/i386, except that I am also getting:

t/op/trans                         (Wstat: 0 Tests: 22 Failed: 0)
  TODO passed:   13

follow-up: ↓ 6   Changed 5 years ago by jkeenan

  • status changed from new to assigned
  • owner set to jkeenan

I'm recommending that we close this ticket because, AFAICT, all the failing tests have been TODO-ed and are being tracked in other TTs.

So if there's no objection, I'll close this in approx. 2 days.

Thank you very much.
kid51

in reply to: ↑ 5   Changed 5 years ago by jkeenan

  • status changed from assigned to closed
  • resolution set to fixed

Replying to jkeenan:

So if there's no objection, I'll close this in approx. 2 days.

No objection raised, so I'm closing the ticket.

Note: See TracTickets for help on using tickets.