Ticket #420 (closed bug: fixed)

Opened 13 years ago

Last modified 13 years ago

Test failures and TODO passes with make fulltest on Ubuntu Intrepid i386 at r37197

Reported by: mikehh Owned by:
Priority: normal Milestone: 1.0
Component: none Version:
Severity: medium Keywords:
Cc: Language:
Patch status: Platform:

Description

Following up on TT#417 and tt#419 by alison

I did a build at r37197

 http://smolder.plusthree.com/app/public_projects/report_details/18732

I then ran make fulltest and got the following:

for -b, -g and -f runcores:

All tests successful.                                                                                                                                                               

Test Summary Report
-------------------
t/compilers/imcc/syn/hll.t           (Wstat: 0 Tests: 2 Failed: 0)
  TODO passed:   2                                                
t/op/exceptions.t                    (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   23                                                
t/pmc/exception.t                    (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   26                                                
Files=252, Tests=8417, 287 wallclock secs ( 2.99 usr  0.69 sys + 76.59 cusr 34.28 csys = 114.55 CPU)
Result: PASS                                                                                        

for the -C runcore an additional TODO passed:

All tests successful.                                                                                                                                                               

Test Summary Report
-------------------
t/compilers/imcc/syn/hll.t           (Wstat: 0 Tests: 2 Failed: 0)
  TODO passed:   2                                                
t/op/exceptions.t                    (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   23                                                
t/pmc/exception.t                    (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   26, 30                                            
Files=252, Tests=8417, 290 wallclock secs ( 2.97 usr  0.83 sys + 77.66 cusr 34.13 csys = 115.59 CPU)
Result: PASS                                                                                        

then the -j runcore failed, but passes the same TODO's as b, g and f:

Test Summary Report
-------------------
t/compilers/imcc/syn/hll.t           (Wstat: 0 Tests: 2 Failed: 0)
  TODO passed:   2
t/op/exceptions.t                    (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   23
t/pmc/exception.t                    (Wstat: 0 Tests: 31 Failed: 0)
  TODO passed:   26
t/pmc/fixedintegerarray.t            (Wstat: 256 Tests: 11 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/library/md5.t                      (Wstat: 1536 Tests: 6 Failed: 6)
  Failed tests:  1-6
  Non-zero exit status: 6
t/library/mt19937ar.t                (Wstat: 256 Tests: 10 Failed: 1)
  Failed test:  10
  Non-zero exit status: 1
Files=252, Tests=8118, 280 wallclock secs ( 2.84 usr  0.65 sys + 75.51 cusr 33.53 csys = 112.53 CPU)
Result: FAIL

At this stage the test exited, so I ran the remaining tests manually.

The make testr failed:

Test Summary Report
-------------------
t/op/pushaction.t                    (Wstat: 256 Tests: 7 Failed: 1)
  Failed test:  6
  Non-zero exit status: 1
t/pmc/sub.t                          (Wstat: 256 Tests: 64 Failed: 1)
  Failed test:  63
  Non-zero exit status: 1
Files=252, Tests=8417, 333 wallclock secs ( 2.63 usr  0.68 sys + 105.04 cusr 53.34 csys = 161.69 CPU)
Result: FAIL

The make testS gave the same results as C

make src_tests and make perl_tests were successful.

make codetest gave the following:

Test Summary Report
-------------------
t/codingstd/c_cppcomments.t  (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1                                           
  Non-zero exit status: 1                                   
t/codingstd/pod_syntax.t     (Wstat: 256 Tests: 2 Failed: 1)
  Failed test:  2                                           
  Non-zero exit status: 1                                   
t/codingstd/trailing_space.t (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1                                           
  Non-zero exit status: 1                                   
Files=28, Tests=356, 215 wallclock secs ( 0.20 usr  0.08 sys + 202.78 cusr  3.27 csys = 206.33 CPU)
Result: FAIL                                                                                       

make benchmark_tests gave the following:

Test Summary Report
-------------------
t/benchmark/benchmarks.t (Wstat: 1024 Tests: 37 Failed: 4)
  Failed tests:  20-23                                    
  Non-zero exit status: 4                                 
Files=1, Tests=37, 683 wallclock secs ( 0.06 usr  0.01 sys + 669.67 cusr  7.89 csys = 677.63 CPU)
Result: FAIL                                                                                     

make doc_tests had NO TEST.

make manifest_tests was successful.

make examples_tests failed:

Test Summary Report
-------------------
t/examples/catchall.t (Wstat: 3328 Tests: 159 Failed: 13)
  Failed tests:  40-42, 44, 63, 65, 72-73, 102, 106, 109-110
                112                                         
  Non-zero exit status: 13                                  
t/examples/japh.t     (Wstat: 256 Tests: 5 Failed: 1)       
  Failed test:  2                                           
  Non-zero exit status: 1                                   
t/examples/shootout.t (Wstat: 256 Tests: 20 Failed: 1)      
  Failed test:  3                                           
  Non-zero exit status: 1                                   
Files=11, Tests=265, 268 wallclock secs ( 0.14 usr  0.03 sys + 16.18 cusr  4.37 csys = 20.72 CPU)
Result: FAIL                                                                                     

and finally make distro_tests failed:

Test Summary Report
-------------------
t/distro/test_file_coverage.t (Wstat: 256 Tests: 3 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=4, Tests=13,  5 wallclock secs ( 0.04 usr  0.01 sys +  3.83 cusr  1.47 csys =  5.35 CPU)
Result: FAIL

Attachments

fulltest_summary.37310.log Download (31.1 KB) - added by mikehh 13 years ago.
summary of fulltest results at r37310
fulltest_summary.37310.2.log Download (31.1 KB) - added by mikehh 13 years ago.
summary of fulltest results at r37310
fulltest_all_summary.37351.log Download (18.5 KB) - added by mikehh 13 years ago.
Latest Test failures and TODO pases summary r37351

Change History

  Changed 13 years ago by mikehh

forgot to set trunk and milestone 1.0

in reply to: ↑ description   Changed 13 years ago by jkeenan

Replying to mikehh: [snip]

make codetest gave the following:

> Test Summary Report
> -------------------
> t/codingstd/c_cppcomments.t  (Wstat: 256 Tests: 1 Failed: 1)
>   Failed test:  1                                           
>   Non-zero exit status: 1 

This is due to a bug in the test reported in TT 414.

> t/codingstd/pod_syntax.t     (Wstat: 256 Tests: 2 Failed: 1)
>   Failed test:  2                                           
>   Non-zero exit status: 1                                   
> t/codingstd/trailing_space.t (Wstat: 256 Tests: 1 Failed: 1)
>   Failed test:  1

Subsequently fixed.

kid51

Changed 13 years ago by mikehh

summary of fulltest results at r37310

Changed 13 years ago by mikehh

summary of fulltest results at r37310

  Changed 13 years ago by mikehh

I have a report on the fulltest results at r37310.

I seem to have managed to attach the file twice. Can someone remove the second file.

This is a summary including the failed tests and passed TODO's.

The tests give the same results as the first test except for codetest and examples_tests.

Test Summary Report
-------------------
t/codingstd/perlcritic.t     (Wstat: 768 Tests: 311 Failed: 3)
  Failed tests:  120-121, 123
  Non-zero exit status: 3
Files=28, Tests=358, 215 wallclock secs ( 0.27 usr  0.05 sys + 202.08 cusr  3.26 csys = 205.66 CPU)
Result: FAIL
make: *** [codetest] Error 1

Test Summary Report
-------------------
t/examples/catchall.t (Wstat: 4096 Tests: 170 Failed: 16)
  Failed tests:  40-42, 44, 52, 54, 67, 69, 76-77, 82, 113
                117, 120-121, 123
  Non-zero exit status: 16
t/examples/japh.t     (Wstat: 256 Tests: 5 Failed: 1)
  Failed test:  2
  Non-zero exit status: 1
t/examples/shootout.t (Wstat: 256 Tests: 20 Failed: 1)
  Failed test:  3
  Non-zero exit status: 1
Files=11, Tests=276, 266 wallclock secs ( 0.17 usr  0.02 sys + 16.16 cusr  4.07 csys = 20.42 CPU)
Result: FAIL
make: *** [examples_tests] Error 1

See the report for details.

Cheers,

Michael Hind (mikehh)

  Changed 13 years ago by coke

FYI, codingstd fixes are probably fixed already.

The examples_tests are failing everywhere, see TT #200.

  Changed 13 years ago by allison

  • milestone set to 1.0

Changed 13 years ago by mikehh

Latest Test failures and TODO pases summary r37351

  Changed 13 years ago by mikehh

Results have got better.

As at r37310:

 http://smolder.plusthree.com/app/public_projects/report_details/18917

testj, manifest_tests, distro_tests and benchmark_tests failed.

doc_tests had NO TESTS.

The other tests were sucessful, however. testbm testC and testS, passed a TODO test, t/pmc/exception.t: TODO passed: 30.

I attached the summary report: fulltest_all_summary.37351.log

Can someone remove the report https://trac.parrot.org/parrot/attachment/ticket/420/fulltest_summary.37310.2.log as it is a duplicate of the previous report that I attached twice.

Cheers,

Michael (mikehh)

  Changed 13 years ago by coke

"make doc_tests" was trying to run a set of tests that no longer exists at that location. Removed the target in r37355.

  Changed 13 years ago by mikehh

As at r37405

 http://smolder.plusthree.com/app/public_projects/report_details/19007

make fulltest_all PASSes everything except testj

TestC and testS pass a TODO - t/pmc/exception.t: TODO passed: 30.

for testj:

Test Summary Report
-------------------
t/pmc/fixedintegerarray.t            (Wstat: 256 Tests: 11 Failed: 1)
  Failed test:  7
  Non-zero exit status: 1
t/library/md5.t                      (Wstat: 1536 Tests: 6 Failed: 6)
  Failed tests:  1-6
  Non-zero exit status: 6
t/library/mt19937ar.t                (Wstat: 256 Tests: 10 Failed: 1)
  Failed test:  10
  Non-zero exit status: 1
Files=255, Tests=8153, 279 wallclock secs ( 2.61 usr  0.65 sys + 74.96 cusr 33.67 csys = 111.89 CPU)
Result: FAIL
make[1]: *** [testj] Error 1

Now if we can just crack the jit stuff.

Cheers Michael (mikehh)

  Changed 13 years ago by mikehh

Great - everything is now passing.

At r37475 everything but one codetest passed - I tracked this down and got the test to pass. It was fixed by moritz++ in r37486. Pre- and post-config tests also pass and smolder
 http://smolder.plusthree.com/app/public_projects/report_details/19095

At r37487 I rebuilt and everything passed except another codetest which I tracked down and got the test to pass. It was fixed by coke++ in r37489. Again pre- and post-config tests all passed and smolder
 http://smolder.plusthree.com/app/public_projects/report_details/19106

With both builds I also built rakudo in a separate directory using
perl Configure.pl --parrot-config=../parrot/parrot_config
In both cases make test/make spectest PASSed.

Looks good.

Cheers,

Michael (mikehh)

  Changed 13 years ago by allison

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.