Ticket #475 (closed bug: invalid)

Opened 6 years ago

Last modified 5 years ago

Could not build parrot-1.0.0 on ppc64

Reported by: JSchmitt Owned by:
Priority: normal Milestone:
Component: build Version: 1.0.0
Severity: medium Keywords:
Cc: rg@… Language:
Patch status: Platform: linux

Description (last modified by doughera) (diff)

Hallo,

I have tried to build parrot on the koji build server. Unfortunately, the build was failed for the ppc64 achitecture.

The build log can you find at:

 http://koji.fedoraproject.org/koji/getfile?taskID=1250229&name=build.log

Best Regards:

Jochen Schmitt

Attachments

build.log Download (14.4 KB) - added by JSchmitt 6 years ago.
Build log from a build ppc64 build from another system

Change History

  Changed 6 years ago by doughera

  • description modified (diff)

The first significant failure in the build log reads as follows:

step auto::alignptrs died during execution: C compiler failed (see test_27215.cco) at lib/Parrot/Configure/Compiler.pm line 104
	Parrot::Configure::Compiler::cc_build('Parrot::Configure=HASH(0x10355688)') called at config/auto/alignptrs.pm line 52
	auto::alignptrs::runstep('auto::alignptrs=HASH(0x107e6450)', 'Parrot::Configure=HASH(0x10355688)') called at lib/Parrot/Configure.pm line 412
	eval {...} called at lib/Parrot/Configure.pm line 412
	Parrot::Configure::_run_this_step('Parrot::Configure=HASH(0x10355688)', 'HASH(0x1063dcf0)') called at lib/Parrot/Configure.pm line 267
	Parrot::Configure::runsteps('Parrot::Configure=HASH(0x10355688)') called at Configure.pl line 75
 at Configure.pl line 75

Note the part that says (see test_27215.cco) . Could you please look at that file and see if it tells you anything useful? For example, I can reproduce similar-looking error messages by including illegal options in the --optimize argument to Configure.pl.

  Changed 6 years ago by rurban

please see tt #364 -xmemalign=4s

follow-up: ↓ 4   Changed 6 years ago by doughera

For some strange reason, Trac did not email my reply to the -tickets list, but instead sent a mail claiming I modified the original description by deleting a blank line.

Anyway, I don't think TT #364 has anything to do with this report, but will await confirmation by seeing the contents of test_27215.cco.

in reply to: ↑ 3   Changed 6 years ago by rg

  • cc rg@… added

Replying to doughera:

Anyway, I don't think TT #364 has anything to do with this report, but will await confirmation by seeing the contents of test_27215.cco.

I'm with Andy here. Also, the big --optimize="..." option looks a bit suspicious to me. You might want to try a build with as few options as possible first.

Changed 6 years ago by JSchmitt

Build log from a build ppc64 build from another system

follow-ups: ↓ 6 ↓ 7   Changed 6 years ago by JSchmitt

I have take a buld of another ppc64 system. I have attached the created build log. Unfortunately, I can't found the fie test_20901.coo from the first error message occured in the build log.

in reply to: ↑ 5   Changed 6 years ago by jkeenan

Replying to JSchmitt:

I have take a buld of another ppc64 system. I have attached the created build log. Unfortunately, I can't found the fie test_20901.coo from the first error message occured in the build log.

I second rg's earlier comment. You are attempting to build Parrot with so many configuration options that it will be difficult for us to isolate the source of the problem.

/usr/bin/perl Configure.pl --prefix=/usr --libdir=/usr/lib64 \
  --sysconfdir=/etc --infodir=/usr/share/info --mandir=/usr/share/man \
  --cc=gcc --cxx=g++ '--optimize=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 \
  -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 \
  -mminimal-toc -maccumulate-outgoing-args' --parrot_is_shared \
  --lex=/usr/bin/flex --yacc=/usr/bin/yacc

I seem to recall that about two or three months ago, someone else attempted to do an optimized build with a list of options as long as this. That attempt failed in a way similar to yours. I recall encouraging the submitter to try again with fewer options, and the results were successful.

At some point Parrot will have been fine-tuned so that it can be built with a multiplicity of options -- and we'll have enough experience to know which options play well with others. But we're not there yet. It would be helpful if you started with fewer options and added them on one at a time until you found the one that wrung the parrot's neck.

Thank you very much.
kid51

in reply to: ↑ 5   Changed 6 years ago by doughera

Replying to JSchmitt:

I have take a buld of another ppc64 system. I have attached the created build log. Unfortunately, I can't found the fie test_20901.coo from the first error message occured in the build log.

Ouch. Sorry about that. Seems Configure.pl is rather silly and deleted the test file. There are two things you can try: 1. Try running with --verbose. That might print the relevant error message. 2. Try compiling some simple "hello, world" type programs with the exact same compiler flags you are trying to use here.

follow-up: ↓ 9   Changed 5 years ago by jkeenan

  • component changed from none to build

We have had no updates on this ticket in 9 months. Since we appear never to have gotten any Smolder reports on ppc64 systems, we're not in a good position to diagnose any of the problems reported here.

I recommend we close this ticket and encourage people with access to ppc64 to submit Smolder reports, preferably initially without command-line options.

Thank you very much.
kid51

in reply to: ↑ 8   Changed 5 years ago by doughera

  • status changed from new to closed
  • resolution set to invalid

Replying to jkeenan:

I recommend we close this ticket and encourage people with access to ppc64 to submit Smolder reports, preferably initially without command-line options.

Agreed. The likely cause was invalid options being passed to the compiler, but we have no way of knowing. I'll close the ticket.

Note: See TracTickets for help on using tickets.